Honda CBR 600RR Forum banner
21 - 25 of 25 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter · #22 ·
really? wow ok well before i do anything else im going to get it compression tested then, it just doesnt make sense because it ran strong only a few months ago... i wonder if something i did maybe threw the valves off and they arent closed at the right time and maybe thats why i dont have compression....

im not expert obviousely, so if compression was my problem, what are all the componets that affect compression?

just piston rings, valve seats, valves and spark plug gaskets right? or would the cylinder head gasket also affect compression, i assume not if the valves are seated properly it would seal off the cylinder from cylinder head... or is that not right?
if cylinder head is a factor then the ignition coil gaskets, reed valves and gaskets and even the air injection control valve also then too, am i missing anything?

thankyou for that information that makes sense now i could not understand why oil would make it combust but not starter fluid, that was extereemly confusing . i just never considered compression because like i said it ran strong just recently with no obvious reason why i would all the sudden have lost enough compression for it to not even start.....
 

·
BOTY 2014 Winner
Joined
·
4,984 Posts
i think with all the messing around you've done you literally just washed it. i bet you've probably cranked this thing with no fire and fuel pouring into it for hours.

the engine won't spontaneously break, you broke it. if it was fine, then you messed with it, and now it's not fine, it's pretty clearly your fault.


you should consider checking timing, though pulling the clutch cover won't mess up the timing, unless there's something else you aren't telling us.
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #24 ·
ok so problem solved (i hope) come to find out i had a faulty ecm this whole time which would explain a hell of a lot so im about to order one... there are only ecm's from 05-06 bikes on ebay right now will those work on an 03? please dont answer unless your 100% sure im tired of guessing on this bike and im so upside down on the thing already i gotta get it running like, yesterday...

anyway i knew it was the damn ecm the whole time but everyone i talked to IN PERSON said oh no try everything else before you replace your ecm, which actually isint bad advice im just sick of wrenching and having nothing to ride...

thankyou very much to everyone who input some thoughts. your knowledge is very valuable to me i appreciate all of you
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #25 ·
for anybody else reading this thread that might have the same issdue as me, the way to find out if your ecm is faulty is... when you go to clear your FI codes., after the procedure your FI light will start blinking 20 blinks means its all good but 33 blinks means your ecm is faulty and needs to be replaced. when i did it i saw it blink a whole bunch i didnt count them cuz it went past 20 aND I THOUGHT IT WAS WEIRD THAT IT DID SO BUT HADNT READ ANYTHING In the manual that made me think it was bad news well good thing i reread it cuz i musta missed that part the first time...haha my life...peace
 
21 - 25 of 25 Posts
Top