Honda CBR 600RR Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I have an 03 rr and when I turn on the kill switch my relay starts clicking like a machine gun, when I press starter button it stops and screen goes blank. I have read other posts about the relay going crazy but all say it happens when the press the starter button, mine goes nuts before pressing it and stops when I press it, any ideas?
 

·
Registered
Joined
·
2,959 Posts
I have an 03 rr and when I turn on the kill switch my relay starts clicking like a machine gun, when I press starter button it stops and screen goes blank. I have read other posts about the relay going crazy but all say it happens when the press the starter button, mine goes nuts before pressing it and stops when I press it, any ideas?
Have you done any recent mods? May just need a new relay.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4 (Edited)
relay clicking

I have not changed anything recently, and the battery is reading at full charge we even tried using my friends relay as they are the same part # and samething happend. We went on about an 50 mile ride yesterday with verying speads.At end of ride bike started fine rode about 30 mile and shut it off to get gas. When I went to crank after getting gas it was like battery was dead. I pushed it to start and headed home. About 5 miles up the road it shut of in the middle of riding and would not restart even with pushing. Just sat there clicking. After getting a truck to get it home battery reads charged and still doing rapid clicking.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Changed battery, now fuse is blowing

So I tried a buddy's battery and it fire right up, so after ordering and installing a new battery now my 20 amp fuse coming off the battery keeps blowing right as I turn the key on. I have followed all possible wires I can think of and can't find any that look cut or like they are touching metal. Any ideas on why this keeps blowing?
 

·
Premium Member
Joined
·
14,330 Posts
Sounds like something is shorting on the wiring going to that relay. A relay will click really fast when it's shorting or wired incorrect. I would check the wiring to that relay for any shorts. The fuse popping is also a sign of shorting.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
Still have yet to figure this out... The only thing I can find that stops it from blowing is by unplugging the bank angle sensor. If this sensor goes bad can it cause a fuse to blow and does this need to be plugged in for something else to get power? Such as something else could be blowing the fuse but since this is not plugged in that piece gets no power to blow the fuse. Thank you for any help with this on going problem.
 

·
Premium Member
Joined
·
14,330 Posts
The BAS is cutting the power to the fuel pump when you turn it on. This probably isn't the issue. If you notice your fuel pump doesn't turn on when the bas is unplugged.

I would put the switch in stop position and turn the key on. This will remove the fuel pump from the equation. if everything is fine and the fuse is good then put it on run. If something happens and fuse breaks then it's your switch/relay/fuel pump that is causing the problem.
 
1 - 9 of 9 Posts
Top