Honda CBR 600RR Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I was replacing the bolt and bulbs that light up my tag and i ended up shorting out my headlights like an idiot so now I need your help to fix my mistake...I've replaced the 20a fuse on the mid left fairing and the 10a fuse for the speedometer because hey both blew when I was messing with the tag, the new fuses get power, the speedometer and dash illumination work but the headlights still won't turn on....I've also checked the wires under the start up button in case they needed to be soldered but they are not loose...if you have any idea on ehat might help me fix this problem without taking it to a shop please let me know thanks
 

·
Registered
Joined
·
77 Posts
My head lights turned on and off a couple times while I was rididng last night too. And my 3rd eye light is spazing like mad . I know its not my wiring harness because I just replaced all of the harness lol.. I'm thinking I might need a new headlight assembly or maybe clean the prongs and check the wires on it I would suggest that to both of you as well..good start anyways
 

·
Registered
Joined
·
1,071 Posts
ya I agree with venom, my guess would be that the bulbs need to be replaced. are they stock ehadlights or do you have HID kit, because I htink the HID's are a little more sensative of a bulb and idk that might have something to do with the problem if you do have aftermarket kit on your headlights... But just my thought
 

·
Registered
Joined
·
176 Posts
+1 Definitely check ballasts.

Also, maybe your ballasts came with inline fuses?
 

·
Registered
Joined
·
1,151 Posts
Try flipping ur brights on. If the bright symbol doesn't change on your dash it means your switch needs to be replaced. This is the case on mine
 
1 - 10 of 10 Posts
Top