Honda CBR 600RR Forum banner
1 - 4 of 4 Posts

· Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
my 2005 cbr600rr engine starts bogging in every gear if i give it gas, no matter what speed. it’ll accelerate slow then gain SOME power, then it’ll struggle at around 12k rpm’s and will only redline if i hold it there for awhile. i changed the fuel pump, chain slack, tires, checked cylinder temp (one of them was a bit lower than the other), coils, plugs, secondary injectors, and air filter and i still can’t figure out the problem. can someone please steer me in the right direction?
 

· Super Moderator
Joined
·
11,962 Posts
I'd say your best clue so far is uneven cylinder temps. i.e. Inconsistent fuel flow. Stop riding the bike until you figure this out. You will burn a hole in the piston if you are too lean.

What did you do when you changed out the fuel pump? Did you check/verify your fuel pressure and flow volume with the new pump? What kind of pump kit did you get? Did you replace the pressure regulator?

Why did you not clean the primary injectors? How many miles are on the bike? Did you pull the spark plugs?
 

· Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
I'd say your best clue so far is uneven cylinder temps. i.e. Inconsistent fuel flow. Stop riding the bike until you figure this out. You will burn a hole in the piston if you are too lean.

What did you do when you changed out the fuel pump? Did you check/verify your fuel pressure and flow volume with the new pump? What kind of pump kit did you get? Did you replace the pressure regulator?

Why did you not clean the primary injectors? How many miles are on the bike? Did you pull the spark plugs?
i just swapped out the fuel pump that was it, i know my way around repairs and whatnot but i’m not an expert. i didn’t check the fuel pressure and i got the QFS Oem pump kit that came with the regulator. i didn’t replace/clean primary injectors cause just yesterday i found out there was more than 1 set of injectors. i have new primary injectors that will arrive in a few days. bike has a new engine which has 10,000 miles on it total. spark plugs are fine. isn’t rich/lean whatsoever but i did see a small splash of oil on one of them.
 
1 - 4 of 4 Posts
Top