Honda CBR 600RR Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1,004 Posts
Discussion Starter #1
So currently my bike is in a different city with my mechanic, and after he did some maintenance on he can't start it... so i have been digging in this forum and in the manual for the past week trying to cover every possibility, as i am determined to take the bus there this thursday and ride away on it no matter what (except if its bad ecu, hiss or fuel pump)
I noticed a couple of things and would really appreciate any feedback/opinions on these:

-What are your thoughts on bypassing the relays (in case they are bad) and riding it that way? namely the engine stop relay, or more extremely the fuel pump relay? (will the ecu even allow it?)
-Also what relays are interchangeable?
 

·
Premium Member
Joined
·
14,330 Posts
Take the ground wire from the fuel pump relay and connect it to the battery ground and see if it will prime. If it does your ecm is most likely bad. The 3 omrons on the side are interchangeable but probably not a bad relay. Have only diagnosed a back ecm by this method, never ridden one while ground wire jumped. Not sure if it will turn itself on/off when needed and might cause more problems for you.
 

·
Registered
Joined
·
1,004 Posts
Discussion Starter #3
I havent had a look at it yet and the guy took it to the dealership and they said it needs a new switch and ECU, but he thinks they are trying to hose me (he's a sportbike mechanic, not a very good one apparently..xS)
I am 99% certain its just the kill switch, as it has been acting up lately where it wont prime one in 10 times until I moved the steering around, didnt want to touch the switch as to not make it worse until I get the chance to open it up....anyway... I am not sure what model you have but my 09 has 4 relays in the fuse box that look similar in the manual (headlight, fan, engine stop and fuel pump)....are these all identical?
Also, are your sure the pump is on a start/stop cycle? I assumed once the engine is started, it keeps running and regulation is left for the injectors (also judging by the diagram...the ECU cant control its +ve terminal, and its not included in the pgm-fi diagnostics)...?

Mayb its also worth mentioning, on my last two rides, about 45 min in the ride the engine light will light up with no mil code, but it will still ride fyn with full power, but once I turn it off and back on, its like nothing ever happened!?!
Any thoughts?
 
1 - 5 of 5 Posts
Top