Honda CBR 600RR Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hi guys,

As the title states, last time I had the bike out everything was working fine, took it out today and the turn signals and hazard lights arn't working, the switch is just dead. Have checked each bulb is working, checked the wires for any obvious damage and also checked the fuses (assuming the TURN/CLOCK fuse is the right one) all are fine. I have read somewhere there is another fuse box behind the front fairing though not sure if this is the case on the 08's?

Would appreciate any help with this as it has me stumped!

Many thanks
 

·
Premium Member
Joined
·
14,330 Posts
I would check your flasher relay. Do you have bulbs or led's as your signals?
 

·
Registered
Joined
·
11 Posts
Discussion Starter #3
Thanks for the quick reply, do you know where I can find the relay? The ones next to the fuse box under the seat don't seem to be the ones I need.

It's just the standard bulbs in the turn signals.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #8
I'm not all that sure on the purpose of them really, I've never used the hazards and its the first bike I've ever had that has them!

I've no idea how to check the relay is working but have ordered a replacment, lets hope it cures it!

Tripage, just checked out your site, do you ship to the UK?
 

·
Premium Member
Joined
·
14,330 Posts
I'm not all that sure on the purpose of them really, I've never used the hazards and its the first bike I've ever had that has them!

I've no idea how to check the relay is working but have ordered a replacment, lets hope it cures it!

Tripage, just checked out your site, do you ship to the UK?
The 2 wire flasher relay won't work on your bike. You need a 4 wire flasher relay. Working to get some made, but don't have any right now. Sorry.
 

·
Registered
Joined
·
1,577 Posts
I'm not all that sure on the purpose of them really, I've never used the hazards and its the first bike I've ever had that has them!

I've no idea how to check the relay is working but have ordered a replacment, lets hope it cures it!

Tripage, just checked out your site, do you ship to the UK?
Where abouts in the UK are you?

You can either modify a stock relay or buy an aftermarket one. I modified the stock one and it worked! check my build thread and you will see.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #15
No I'm still running the standard bulbs at the moment, planning to upgrade asap though along with some HIDs and an LED tail tidy

Unrelated but our bikes are a spit of each other lol

 

·
BOTM winner 03/15
Joined
·
2,308 Posts
If you plan on getting LED's in the future you'd be well advised to buy the relay in the link. It'll work fine with regular bulbs until you come to install LED's, and it'll mean you won't need to wire resistors in line with the new indys. You'll be all set! :)




Sent from Motorcycle.com App
 
1 - 17 of 17 Posts
Top