Honda CBR 600RR Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter #1
Hey .net,

My 09 Phoenix check light started blinking a couple weeks ago. With the kickstand down, i get 2 short flashes and with the kinckstand up , the light stays on continuously.

From what i`ve read , the 2 short flashes indicate a 02 code = MAP sensor , however, i had the bike checked by a mechanic and he says its the kickstand sensor.

Does anyone else have/ had this problem and what what the fix? Is it MAP sensor or kickstand sensor or something else?

any help will be appreciated.

Thanks
Rocket
 

·
Premium Member
Joined
·
13,137 Posts
Your mechanic is an idiot.

It is supposed to stay on with the kickstand up, it will also stay on if you go over 5k rpm.

And yes, you have a MAP sensor malfunction. Check the vacuum system for leaks and failing that replace the MAP sensor.
 

·
Registered
Joined
·
55 Posts
Discussion Starter #3
Thanks Nico, I thought the same.

Assuming the sensor is gone, what causes the sensor to fail? Is there a hidden root cause ?

I`m thinkin to do the fix myself but no sense changing the MAP if it will fail again.

Suggestions?
 

·
Premium Member
Joined
·
13,137 Posts
Thanks Nico, I thought the same.

Assuming the sensor is gone, what causes the sensor to fail? Is there a hidden root cause ?

I`m thinkin to do the fix myself but no sense changing the MAP if it will fail again.

Suggestions?
Sometimes they will just go...

Not sure of the setup on the 09s, but if it has a vacuum line check it first, just pull it off and have a suck on it... but I think it may be mounted on the back of the airbox and plumb straight in there, in which case just replace the sucker...
 
1 - 4 of 4 Posts
Top