Honda CBR 600RR Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter #1
Ok so battery is fully charged, gear is in nuetral, kickstand is up, killswitch is in run position, fuel pump primes, but when the starter button is pressed nothing happens.

My brother rode over on his lunch break, went to leave and it wouldnt start.
I loaned him my car so im hoping to have it running for him when hes off work.

Any ideas? I think it might be a fuse
 

·
Registered
Joined
·
141 Posts
The kill switches on these bikes are known to be troublesome over repeated use.

I would check there after fuses. (others with more experience may chime in with things to try first)

Have you visually inspected the kickstand switch to see if it looks like the wires are connected or if there is any damage?

Just tossing out where I would start with my limited knowledge
 

·
Registered
Joined
·
35 Posts
Discussion Starter #3 (Edited)
I ride an 06, not sure where the fuses are on an 08 do you know?
Headlights dont come on, is that normal for an 08?
How do you tell if the kickstand switch is working properly?
 

·
Registered
Joined
·
141 Posts
The relays and fuses are under the seat in a rectangular box on the shifter side.

I ride an 06, not sure where the fuses are on an 08 do you know?
Ill go check for loose wires on the starter switch and the kickstand...
 

·
Registered
Joined
·
141 Posts
headlights should come on when you turn the key, you can pull the wires from the switch on the kickstand and twist them together to bypass the switch. I would check relays and fuses before pulling the kickstand wires though.
 

·
Registered
Joined
·
35 Posts
Discussion Starter #6
ok so the headlight fuse was popped, i replaced it and the bike started but blew the fuse in the process (aka, dead again).
So he can get home without headlights but will blow another fuse. He has HID's installed but theyve never given him a problem.

I cant figure out how to open the headlight relay cap, so i cant look at that.
ideas?
 

·
Registered
Joined
·
141 Posts
ok so the headlight fuse was popped, i replaced it and the bike started but blew the fuse in the process (aka, dead again).
So he can get home without headlights but will blow another fuse. He has HID's installed but theyve never given him a problem.

I cant figure out how to open the headlight relay cap, so i cant look at that.
ideas?



You'll have to hope someone else chimes in now, I have no experience with hids
 

·
Registered
Joined
·
81 Posts
Take a look at the metal prongs where the bike harness plugs into the HID plug could have a bad plug. If prongs are black u need to cut plug out an replace it iv seen it a few times with HID an even without
 
1 - 9 of 9 Posts
Top