Honda CBR 600RR Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Ok I have a 2005 Honda cbr 600rr. I have checked all relays , cut wire harness completely open , taped repaired any possible short. Run switch works, I have a service repair manual(2003 version) but there is not one for the 05 06 I can find. Bc there are differences in the electrical system between 03 04 and 05 06. When i by pass the BAS by jumping the red and green wire together fuse blows when I turn on kill switch to run. When I leave open fuse is fine. Any help is appreciated. I am an electrician by trade and descent mechanic. Only thing I can think of is ECM is bad. I’m assuming my problem is right there but I know there are several components on this circuit. Thank u for any advice. Brand new battery. This all started when I did a wheelie came down hard and lights blinked. 20 miles later bike electrical fails. Well I pull over battery was warped it was soo hot. But fuse wasn’t blown then. Bike wouldn’t turn over and relays buzzed. R/r is on the way. But I unhook the r/r and fuse still blows.
 

·
BOTY 2014 Winner
Joined
·
4,903 Posts
the fuse by the battery is the EFI fuse. it runs the entire FI system (fuel pump, ecu, fuel injectors, spark plugs, the whole bit)


the engine stop relay powers up this circuit


the engine stop relay is controlled by the kill switch on the front side of the coil, and the bank angle sensor on the back side of the coil (basically 12v is supplied to the coil by the kill switch, and the ground is supplied to the back side of the coil by the bank angle sensor, this is why you connect red to ground to bypass the sensor. the circuit that controls the engine stop relay is NOT the 20amp fuse that is blowing on your bike. the circuit that controls the relay is the IGN circuit in the fuse box. it's keyed power, the EFI circuit is not. if the IGN fuse doesn't blow there is nothing wrong with the kill switch, the bank angle sensor, or the engine stop relay)


when you ground the red, you are pulling the engine stop relay and powering up the EFI system. if the fuse blows it's because you have a short in the EFI power circuit. this could be found in MANY place. all fuel injectors, the fuel pump, the ignition coils, etc.




keep this in mind when you look for your trouble, hope this gets you started in figuring out what's wrong.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
Thank u for your response. Yea relays are all good. I was hoping it was something simple. But I’m gonna have to pull air box and go through coils and injectors. I wish I had a test harness for ecm. Bc I have read that the ecm goes bad and does this as well. I’m thinking something got really hot and shorted to frame or circuit to circuit? Idk just soo frustrated with it. Wish I could find someone with a salvage bike in my area. Switch ecm so I could rule it out. Well back to searching. I appreciate it. Atleast I’m on the right track. Thanks again.
 

·
BOTY 2014 Winner
Joined
·
4,903 Posts
if it were me i'd just set my multimeter to resistance, put one probe on the load side of the engine stop relay, and the other lead to battery negative.

then start unplugging things till the resistance goes up. i presume it's a short so it should be pretty easy to find



if you buy anything at this point you're wasting your money. speculating on the issue with your wallet is the stupidest way to troubleshoot. if you're an electrician this whole problem should be a non issue.


you don't need a test harness to check anything on the ecu, you can just insert a paper clip into the rear of the connector and meter to that.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #6
Yea but I’ve tried everything and the wiring diagram is not accurate I have an 05 the only service manual I can find is for an 03 04. There’s not even a connection at slot 14 on the light grey connector on my ecm but apparently there is for a 03 04. I really think it’s ecm bc others have had it happen and there are no signs of melting or heat abrasion on any wire? I’ve got 40 hrs in it looking. Idk... I’ll try that but at this point I don’t have but 18$ in plus a circuit breaker and fuses. So I’m 36$ in. Another 100$ just to see would give me peace of mind. I hear what ur saying. I appreciate it. I’m sure I’ll be back with more questions or needing some guidance it’s not like I work on these for a living. Dc theory is a Lil different than running conduit, duct banks, panels, etc. occasionally I’ll wire up a plc not a lot of control work at the moment. I’m a way better mechanical electrician than control electrician.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
Ok the black and white wire in the light gray connector is getting severely hot and has damaged a female prong inside harness. Ecm side is hot as well. Not sure what that wire is bc my wire diagram is not accurate. Unhooked every component with no resistance reading on the load side of relay and negative terminal in battery. Thinking ecm is bad might have to replace harness as well. What do u guys think?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #8
If your looking down at the bike like u were sitting on it it’s the throttle side top wire Light grey connector
 

·
BOTY 2014 Winner
Joined
·
4,903 Posts
if you want to know if it's the ecm just unplug it and see if you still have issues.


where does the connector go? i don't have an 05, but it's probably the kill switch pod? i suspect the black white goes to the load side of the kill switch, based on how honda tends to wire their bikes.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #11
there are no o2 sensors on my bike that I can find? California models only? I unplugged grey connector and fuse doesn't blow. ive checked everything except injectors and purge control solenoid valve. my buddy has a 05 honda cbr 600 going to buy it for parts wish I would have remebered before spending 125 on an ecu...
 

·
Registered
Joined
·
8 Posts
Discussion Starter #13
ok got it figured out I knew I was right it was the ecu. Replaced it fuse didn't blow bikes running fine. but I learned some things so it is what it is. appreciate all your help and input
 
1 - 13 of 13 Posts
Top