Honda CBR 600RR Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I bought this bike last spring, and I can safely say I will never get rid of it. This bike belonged to my friend Bryant before he passed away. That being said, I really cannot ever get rid of it. This was his pride and joy. I'm reaching out to you guys for help on this one.

I've been an auto tech for the past decade, first streetbike that I've owned. That being said, I'm not worried or unqualified to be working on this. And I won't need any dumbed down answers either haha

My 05 CBR 600 RR has almost 29,000 miles now. One issue I've had since about the middle of the summer, was the tachometer stopped working. When I flip the key over, it spins to the end and back as it should. Just stays at zero while the bike runs. Just recently, it's quit starting. I get a strong click around the battery area, but no crank, no start. The battery has been charged up full, I can verify that isn't my issue. When I attempt to start it, it clicks, and also resets the clock. I had been running the bike on a weekly basis before this began.

I'm working on getting the manual for the bike soon. Just looking for help from others who may have been down this road. Thanks!
 

·
Registered
Joined
·
862 Posts
Try giving the starter a direct 12v from the battery or another source. If that turns it over then you're looking at dead wiring, switches, or relays somewhere in between the battery and the starter. If not, the starter is hosed. That's about all I can suggest from the little information you gave.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
I'll be getting a power probe from work pretty soon to try this. Thanks for the quick reply!
 
1 - 4 of 4 Posts
Top