Honda CBR 600RR Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
Hey guys,

2009 Cbr600rr w/ 12000 miles and just had the oil changed.

So I noticed on the freeway the other day I could get up to about 87mph but it would drop back down to 81 and refuse to go any faster all (Was in the middle of trying to get into carpool lane and get with the flow). Thats the same for 5th, 4th, and 3rd gear, I did some quick testing today for 2nd gear and it hit 7k rpm and literally stayed there at full throttle. I shifted up to 3rd and it did climb some but again refused to go past certain rpm points.

I've read and read the threads here and will be pulling the tank off this week.

Currently on the bike is a Power commander 5 (i swapped mapped with one off the website) and I do have a different than stock battery (i saw some say a lose connection could cause something) K&N Air filter.


So things to look at? Fuel pump? Injectors? Kinked fuel line? Spark plugs?


I've never taken the tank off or checked any of the items listed so I'll need to look on here for some DIY's.. but any info is always appreciated.
 

·
Registered
Joined
·
48 Posts
My first guess would be at the power commander. If it simply wont rev but has no issues with misfiring or power up to that point i seriously doubt its a spark or fuel issue.
 

·
Registered
Joined
·
5,266 Posts
FWIW, about 3 years ago,

On my 09, had the bike go into limp mode after longer rides......and wouldn't rev......rode home about same way your bike sounds like it is riding currently.

MIL light threw a TPS sensor position code.....with laptop/DJ program hooked up to PC 5 checked throttle setting/position and could see it fluctuating erratically, and reading crummy values at closed throttle.

Removed pc 5 and ran bike w/o probs.

Sent my suspect PC5 to DJ.....asked for testing, (ask for express service =extra$ 35)
and they sent me a new PC5 on warranty and refunded the express service charge.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #5
interesting! Okay I'll remove the PC5 and see.. Do I have to flash a stock map or when i remove it does it just go back to stock map?
 

·
Registered
Joined
·
48 Posts
I would think your bike would run on the stock map since the OEM ECU would be controlling. Or are you asking about the pc5?
 

·
Registered
Joined
·
26 Posts
Discussion Starter #7
I would think your bike would run on the stock map since the OEM ECU would be controlling. Or are you asking about the pc5?
I just wasn't thinking, I was questioning if the Pc5 was flashing the ECU a new map instead of just the Pc5 being flashed and changing the values. So yes I suppose removing Pc5 means ECU is running stock.
 

·
Registered
Joined
·
5,266 Posts
you can run a "zero map" on the pc5.

be careful removing pc5 from harness, and be very careful not to pinch tubes when raising /lowering tank.....
 

·
Registered
Joined
·
26 Posts
Discussion Starter #10
Zero'd the map and no luck, tore it apart today and pulled the battery (gel cell battery) and brought it over to honda motorcycle dealer and had them test it and they said its bad. So I have a new battery and oem air filter with some fuel injector cleaner going in tomorrow. We shall see what happens!
 

·
Registered
Joined
·
26 Posts
Discussion Starter #12
Just wanted to close this out by saying it turned out to be a bad PC5, I removed that and went for a ride and issue was completely gone.
 
1 - 13 of 13 Posts
Top