Honda CBR 600RR Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
Dont want to get into too much detail but I had an instance where I panicked and used too much front brake. Bike endo'd and went over along with me, it my helmet, right hand and right leg on the ground. Rode the bike home and everything seems fine.

Damage appears to be pretty much cosmetic but just want to get some input from the 600rr members. Both mirrors are gone, windscreen gone, taillight cracked, rash on the top part of the front upper fairing, right side fairing has a little rash, rear tail has a little rash spot aswell. Doesnt appear to be much major damage. The upper fairing stay is bent and the cluster came off its mounts. The crash happened when i was going about 30km/h so very slow and I stopped before I went fully over. Nothing appears to be tweaked or misaligned and as I said I rode it home without issues except my hand hurting.

Anything I should be concerned about?
 
K

·
Guest
Joined
·
0 Posts
if it drives, it's working ok. mechanically, it doesn't sound like anything is messed up.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #3 (Edited)
if it drives, it's working ok. mechanically, it doesn't sound like anything is messed up.
Yeah everything works and it drives fine.

Now ive ran into an issue though. I thought my upper fairing stay was bent which was causing at full lock the right clip-on and controls to hit the windscreen and bracket. After looking at it and playing around with putting it on the bike I dont think the fairing stay is bent but I could be wrong. The little L bracket that goes from the mirror to the middle bolt of the windscreen on that side was bent so I bent it back into shape today but it is still hitting. I took some pics and attached them below. I am thinking the clip-on may have shifted since the fall mostly happend on that side....any tips or help is appreciated.

With front fairing on

steering centered


 

·
Registered
Joined
·
17 Posts
Discussion Starter #5
no pics.

could be the clip-on tab broke off and is cocked.
Sorry about that, pictures were taking longer to email then I expected, linked them now. I will add a few more with the little bracket in place showing the contact.

Any pics of the clip-on tab?
 
K

·
Guest
Joined
·
0 Posts
it's probably bent up, not tweeked to the side... afterall you said the dash fell off...
 

·
Registered
Joined
·
17 Posts
Discussion Starter #7
it's probably bent up, not tweeked to the side... afterall you said the dash fell off...
Yeah the instrument cluster broke off its tabs, pretty much went straight forward and over but I believe it tilted to the right as my left side is completely unscathed whereas the right as all the rash etc.

So the clip-on may be bent upwards? Anyway to fix this or replace only?
 

·
Registered
Joined
·
17 Posts
Discussion Starter #10
Damn, thats what I wasnt hoping for. The stay fits perfect on the front fairing so I figured it was fine.

Side View


 

·
Registered
Joined
·
17 Posts
Discussion Starter #12

·
Registered
Joined
·
17 Posts
Discussion Starter #13
stay is bent. KR Tuned has a shnazzy CF replacement!
I know its probably hard to tell from the pics etc but would you guess its the ear section thats bent back or the middle T section? I took off the piece just now and put the ear in a vice and bent it backwards some and it seems to definitely fit better, hard to tell in the dark without the brackets etc
 
K

·
Guest
Joined
·
0 Posts
it's hard to tell what's bent to be exact. it APPEARS that the ]fairing stay is what's bent...
 

·
Registered
Joined
·
17 Posts
Discussion Starter #15
Gonna spend some time tomorrow and try and bend the right side part of the fairing stay that bolts to the mirror and hope I can get it to line up somewhat.

Most likely will need to replace it im guessing as I probably wont get it 100% but would like to get it back reasonably so I can get back riding!!!! :)
 

·
Registered
Joined
·
17 Posts
Discussion Starter #16
Ok I put the front end back on and got the bolts all lined back up with a little force, still slightly hits the fairing stay/bracket but thats only at full lock when its parked.

Just took a little 1st gear spin in the parking lot and noticed something that may have been there before but might not have been. The bike runs and rides fine from what I could tell, the only odd thing I noticed was with the clutch. When I let out the clutch it feels normal up until I fully release it, when I fully release it I am feeling/sensing some sort of drag/grinding/rubbing. If I take up the little bit of free play on the clutch lever before it actually starts to pull the clutch in the feeling goes away completely. Hoping I just need to adjust the lever to get rid of the free play but wanted to check here since you have been of great help so far
 
K

·
Guest
Joined
·
0 Posts
Ok I put the front end back on and got the bolts all lined back up with a little force, still slightly hits the fairing stay/bracket but thats only at full lock when its parked.

Just took a little 1st gear spin in the parking lot and noticed something that may have been there before but might not have been. The bike runs and rides fine from what I could tell, the only odd thing I noticed was with the clutch. When I let out the clutch it feels normal up until I fully release it, when I fully release it I am feeling/sensing some sort of drag/grinding/rubbing. If I take up the little bit of free play on the clutch lever before it actually starts to pull the clutch in the feeling goes away completely. Hoping I just need to adjust the lever to get rid of the free play but wanted to check here since you have been of great help so far
i get that too, and my bike has never been down. i think it's just a wobbling pin.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #18
Hmm, well thats good news then. I probably never noticed before and am just being overly concerned. I will probably just adjust out the slight free play in the clutch lever.
 
1 - 18 of 18 Posts
Top