Honda CBR 600RR Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
Ok did a search last night couldnt find anything please any advice is much appreciated.

Had power commander installed left perforamce shop every thing seemed fine looked at install under the pass. seat when i started the bike, the power strip did its night rider thing on the PC3 put seat back on left rode to my friends house with him from the shop. left his house went to get gas filled her up she wouldnt start. Opened passenger seat turned key to ignition no knightrider or power up to the PC3. Bike makes starting noise but never turns over. To dark trouble shoot fuses pushed bike to his house but i did check the battery lead which was still connected. Bike is stock with PC3 set to no map. i felt the throttle wasnt as responsive when i left but coulda been in my head. I bought the PC3 used from a buddy with the same 07 blue and silver. i got the PC3, front fender(cracked mine with disc lock) and flushies for 200 bucks.

Any ideas please help.

PS. My friends ZX-10 pulled 159hp and 78lbft with just akra bolt on mufflers BMCfilter, and PC3

PPS while i was there, two brand new 1000rr's one getting akra carbon/fullsystem PC3,BMC, and custom dyno tune only pulled 155hp

Another customer same bike a brand new 1000rr, just a jardine slip on,BMC,PC3 and custom dyno tune pulled the same 155hp

I looked at the akra headers, same exact diameter as stock. looked like the same header.
 

·
Registered
Joined
·
810 Posts
check the pc still has power / earth.
Make sure All connections are correct.
If still not working - disconnect the pc from the injectors & the TPS. then test bike.
 

·
Registered
Joined
·
2,120 Posts
Check your power first. Then maybe one of your injectors came unplugged but I think the PC should still light up even if that is the problem but I can't say that for sure. If those don't work, take the PC out and if the bike starts, It's the PC. If not, it's something else.
 

·
Registered
Joined
·
1,735 Posts
Ive had that. The bike wouldnt start so I looked around and finally disconected the PC3 and Bam!! The bike fired up. Power commanders are junk in my opinon. I bought mine new and it was 6 months old at the time.
I called dynojet and they said they would be glad to sell me another unit.
 

·
Registered
Joined
·
211 Posts
I bought a used one PC before, turned out to be a frustrating lesson. You get what you pay for.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #6
Thanks all you guys turned out to be a bad ingnition switch the red toggle. it would turn the injectors on when it felt like working maybe one out of every 10 times playing with the switch.... when the injectors would prime the PC3 would turn on and bike would start... could be cause the bike used to sit in the rain sometimes before i moved to my new apartment with covered parking, any how guess the problem drove me to buy a BMC race filter and get the custom tune done with factory exhaust while i wait for my new arrow system to come in, guess its a waste of money but the second map is half price and i like to see numbers with different maps/mods.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #7
I called dynojet and they said they would be glad to sell me another unit.

Thats fawked up JP i thought it said glad to send you another unit not sell.
My installer is a PC3 authorized dealer/tuner he seems to have some pull so im not worried within the year.

I just hope this isnt the start of a lot of problems. i was just gonna do a slip and leave it alone dont want to kick myself.... like with my A6 expensive maintainence after the chip
 

·
Registered
Joined
·
1,705 Posts
i'm having the same problem now and i just got it back from dynojet asking to get it repaired and same thing again, nothing working only when i take it off.
 

·
Premium Member
Joined
·
13,137 Posts
Is this a problem only on the PC3? I have a PC5 and BMC at home im waiting to put in until I get to NC and get dyno'd up. I might just return the PC if its had so many problems...
Just the PC3, not an overly common issue but common enough. They have sorted it out with the newer PC3s though...
 
1 - 11 of 11 Posts
Top