Honda CBR 600RR Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
05 600RR has been sitting for years. Pretty much started it here and there to take it down the block. One day the bike was tipped over. (bro in law took it for a spin and didnt put kick stand all the way down) Bike didn't want to start ever since. I checked all the fused and got nothing. Thought it was the fuel pump so i bought a used one off ebay. Same sh*t. Doesn't start. Gauge won't work either. Lights just blink and HID's won't come on. Bike has a new battery. Did some reading on here and learned to bypass the BAS. Wired it up and BOOM! Gauges work perfect and HID's are on HOWEVER, the pump still won't prime. I opened up the intake and sprayed starting fluid to see if it would atleast turn over with that but it hasn't. What do I go guys? I need this bike gone. Haven't rode in years and don't plan on it as I have a child now. Need your help asap. Bike only has 2,500 miles. Its mint.
 

·
Registered
Joined
·
2,060 Posts
Check your kill switch, kickstand switch and clutch switch, guessing one of those is bad, especially if your BAS is messed up. Search on here for those items or look in your service manual.

My guess is the BAS is fine and one of the others is bad, bypassing it really isn't a good thing in the long run and was only a symptom. My money is on kickstand switch.

Mike
 

·
Registered
Joined
·
15 Posts
Discussion Starter #7
Ok, I'll search on how to bypass those. Only bypassed the BAS to see if it was the problem. It has to be damaged because it would not let the lights or gauges come on. Now I just need to figure out whats holding it from starting.
 
1 - 7 of 7 Posts
Top