Honda CBR 600RR Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi,

I've got rear seats on my bike which shouldn't affect the operation of the brake light.

However, it does not trigger the brake light once applied.

Not sure what's the issue as the light works with front brakes but not rear.

Any troubleshooting recommendations.

TIA

Moustafa
 

·
BOTY 2014 Winner
Joined
·
4,892 Posts
is the brake light switch installed? it looks like this

a lot of aftermarket rearsets don't accommodate this switch. if it's not there then the answer is pretty obvious.
 

Attachments

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Thanks Wibbly. spot on.

Yes correct there is no brake light switch as I checked.

I can't locate the harness though so I'll take the seat off and check underneath.

Do you happen to have the service manual for 13-17 cbr.

Thanks.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Hi guys

I’ve taken a deeper look at the bike.

Unfortunately I couldn’t find the harness that I am supposed to connect to.

So went ahead and taken off the seats and checked all wires.

There is a green wire which I suspect it’s for the rear brake light because after testing it’s the only one that doesnt affect my current brakes or turn signals.

It’s actually damaged or frayed but not sure best way to remedy as I’m not good with electronics but don’t want to leave it like that which can damage my bike.

I also am curious to know what does that red big fuse do.

Any advice much appreciated.

photos attached as well
 

Attachments

·
Registered
Joined
·
111 Posts
Hi Have a look in the motorcycle manual for your model, It's got lots of valuable information Such as the the Main fuse you see there which i believe is a 20amp PGM FI fuse. If this was blown it would effect allot more then just rear lights

Regarding the harness, i'm not experienced enough to say however it should be clear due to the fittings. Really need to look at the Manual as it will give you a clear image of what you need compared to what you have..

A quick search online:

https://www.google.co.uk/search?q=honda+600rr+2013+manual&oq=honda+600rr+2013+manual&aqs=chrome..69i57j0l2.16780j0j7&sourceid=chrome&ie=UTF-8

Also some close up images would really help here, just a thought.

Hope that helps, i'm sure it's nothing to worry about. Might as well get some mini 20 & 10 amp fuses. Their handy especially if your new to electronics and last but not least always disconnect the battery when working with the wiring, just a reminder..

Take it easy
 

·
Premium Member
Joined
·
14,330 Posts
The red cap is your data port plug.

Looks like you have aftermarket rearsets on the bike. I would guess that they don't have a spot for oem spring type brake connection or previous owner didn't want a rear brake connection and left it off.
 
1 - 9 of 9 Posts
Top