Honda CBR 600RR Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
431 Posts
Discussion Starter #1
Hey, So i have put up with this problem since day 1 that i bought my bike. Which was 2 years ago. I have a 03 Cbr 600rr and the 2 black buttons on my cluster will not do anything. I can't reset my trip meter or change from trip (A) to (B) or anything. I thought about taking the buttons off and seeing if there is anything i can do to activate them again. The place i bought it from said that I would have to replace the whole cluster, that you cant just fix the buttons. Has anyone experienced this problem and if so PLEASE how did you fix it? It not crucial but it is annoying that it doesn't work:banghead:
 

·
Registered
Joined
·
186 Posts
Yes you can fix it and there is alot of information here on this website. I ended up getting rid of those rubber inserts and put some screws in (after cutting the head of the screws) and they work perfectly.
 

·
Administrator
Joined
·
51,151 Posts
I found this write up by em2b96p from 2004 thread

All you gotta do is :

1) remove both mirrors from fairing by taking out the 2 SMALLER alan screws at the base of the mirror stalk.

2) remove windshield screws and remove windshield.

3) see the T shaped support the cluster is mounted on? well unbolt the two 12mm bolts holding the support to the frame between the forks. careful not to scratch the forks with the tools.

4) ( WARNING: next step WILL ERASE the Trip A and Trip B odometers but not the actual mileage odometer.
---unplug the harness from the back of the cluster.

5) remove the 3 screws holding the cluster to the T support thing.

6) pull cluster off of T support.

7) ( WARNING: touch metal to ground yourself prior to this step)
---- remove the 8 small screws on the back of the cluster.

8) ( WARNING: touch metal to ground yourself prior to this step)
( (WARNING: becareful NOT to touch the needle ( or face).)
--- pull back cover off. lift up circuit board by holding the edge. carefull the white plastic that broke off the button might get lost if it falls. ( do not remove any of the screws on the circuit board)

9) ( WARNING: touch metal to ground yourself prior to this step)
---- the little white plastic looks like a "T" apply very little glue to the wide end of the little white plastic "T" piece. place over button and make sure it is seated properly. to test push the button and it should make a "CLICK" noise.

10) reassymble in reverse manner.


Difficulty scale ( 1-10): i would rate this a 4. not hard at all jst remember to tighten everything down or else it will contribute to the BUZZ or Rattle problem the 600RR seems to be plagued with.

feel free to ask any questions.

Hope this helps :bounce:
 

·
Registered
Joined
·
186 Posts
I found this write up by em2b96p from 2004 thread

All you gotta do is :

1) remove both mirrors from fairing by taking out the 2 SMALLER alan screws at the base of the mirror stalk.

2) remove windshield screws and remove windshield.

3) see the T shaped support the cluster is mounted on? well unbolt the two 12mm bolts holding the support to the frame between the forks. careful not to scratch the forks with the tools.

4) ( WARNING: next step WILL ERASE the Trip A and Trip B odometers but not the actual mileage odometer.
---unplug the harness from the back of the cluster.

5) remove the 3 screws holding the cluster to the T support thing.

6) pull cluster off of T support.

7) ( WARNING: touch metal to ground yourself prior to this step)
---- remove the 8 small screws on the back of the cluster.

8) ( WARNING: touch metal to ground yourself prior to this step)
( (WARNING: becareful NOT to touch the needle ( or face).)
--- pull back cover off. lift up circuit board by holding the edge. carefull the white plastic that broke off the button might get lost if it falls. ( do not remove any of the screws on the circuit board)

9) ( WARNING: touch metal to ground yourself prior to this step)
---- the little white plastic looks like a "T" apply very little glue to the wide end of the little white plastic "T" piece. place over button and make sure it is seated properly. to test push the button and it should make a "CLICK" noise.

10) reassymble in reverse manner.


Difficulty scale ( 1-10): i would rate this a 4. not hard at all jst remember to tighten everything down or else it will contribute to the BUZZ or Rattle problem the 600RR seems to be plagued with.

feel free to ask any questions.

Hope this helps :bounce:
This is one option but to fix mine all I did was remove the little black rubber peice over the buttons.

Screw I used:


 

·
Registered
Joined
·
431 Posts
Discussion Starter #9
Wow awesome , very VERY helpful guys. Ima go home today once I get off work and go try this. Would wearing rubber gloves help with the touching of the cluster?
 
1 - 10 of 10 Posts
Top