Honda CBR 600RR Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
228 Posts
Discussion Starter #1
I had to replace the oil seal in my clutch cover linkage and now I can not for whatever reason get the clutch cover back on. I've wiggled it, moved it, tilted it, jiggled it all while moving the lever clockwise. It wants to catch, but I can't get it on far enough to catch. Seems like its getting hung up on something. Seems to be held up on those dowel pins coming out from those two gears: The cover will pivot on the area where those pins stick out, but I can't get it on far enough for it to catch. I'm about to lose my sh*t!!!!!!!!! Apparently a valve adjustment is no issue, but I am incapable of re-installing my clutch cover....:cursin:

 

·
Registered
Joined
·
228 Posts
Discussion Starter #2
Solved. Apparently the starter reduction gear can sit in two slightly different positions depending on how everything is oriented. I simply had it in a little tweaked and it was bound up causing the pins not to align.
 

·
Registered
Joined
·
7,045 Posts
I'm assuming the wave washer helps keep everything pressed together. On my first attempt to re-install the cover I swapped the two washers around and the bike wouldn't start; so it seems pretty important that they are in there and in the right order even though they look totally insubstantial.
 

·
Registered
Joined
·
228 Posts
Discussion Starter #6
I'm assuming the wave washer helps keep everything pressed together. On my first attempt to re-install the cover I swapped the two washers around and the bike wouldn't start; so it seems pretty important that they are in there and in the right order even though they look totally insubstantial.
Ah that would drive me nuts if it didn't start. Fingers crossed mine starts.
 
1 - 6 of 6 Posts
Top