Honda CBR 600RR Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
I got my bike jsut over a years ago and i start having problems with it around 12000 miles the bike would shut off and not run for days and then run fine for days and then i took it to the dealership first they said fuel relay and that didn't help and then they told me a bad switch and now they can't tell me anything till it starts messing up again. i don't want to ride it to make it mess up cause i don't want to be in a intersection when it decides to mess up any advice
 

·
Administrator
Joined
·
51,153 Posts
do you have a power commander installed ?
 

·
Registered
Joined
·
23 Posts
Discussion Starter #4 (Edited)
yeah i have a power commander installed and it has ran for about 11000 miles before i started having problems and the dealer says they can't do anything till it fails in the shop where they can trouble shoot it and i'm up to about 14100 now i was wondering if there is some kinda of recall or some bs like that
 

·
Administrator
Joined
·
51,153 Posts
if you got problems i bet its the power commander take it off
and ride without for a week if you still have problems during that
week then its not the PC but if the problems go away then its the PC
 

·
Registered
Joined
·
11,434 Posts
Call Dynojet with your serial number and see if you have a defective PC. If the PC is good then check the safety neutral switch, side-stand switch, and the BAS for faults. Make sure the BAS isn't loose. Check all of your PIN connectors for tightness. Check you ground on the left side of the frame and make sure it's not corroded. Check both battery terminals and the battery voltage.
 
1 - 6 of 6 Posts
Top