Honda CBR 600RR Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
Alright I need help, after a ride I noticed I had a wet spot underneath my bike and it turned out to be coolant.
My radiator reserve tank was filled up and leaking through the overflow hose.
The manual states :
Coolant leak
• Faulty water pump mechanical seal
•Deteriorated O rings
•Faulty radiator cap
•Damaged or deteriorated cylinder head gasket
•Loose hose connection or clamp
•Damaged or deteriorated Hose

so I started off with the Rad cap but it’s still having the issue, before I replaced the cap I made sure the air in the system was bled, while doing so I noticed a white milky substance float to the top of filler neck, just A small price so I took it out. Oh and it also looks like there’s a bit of the white substance sitting on the bottom of my radiator reserve tank.
So my next step will be to drain the coolant and flush it

but is there any info you guys can give me? Please help I want to ride
 

·
Registered
Joined
·
735 Posts
Make sure you don't have hoses reversed...

Hose to radiator cap should be bottom one. Overflow goes out top hose.
 
  • Like
Reactions: Kareem O Wheat

·
Registered
Joined
·
22 Posts
Discussion Starter · #3 ·
Alrihht so I’ve tried doing a combustion leak tester ( where the fluid turns yellow if contaminated ) and it stayed blue so there’s no gases in my cooling system, I also tested the thermostat and works as suppposed to.

I also did an oil drain but couldn’t tell if it was mixed with coolant or just ugly 2.5k miles oil

also did a compression test and my numbers were 110,115, 116, 109
i appreciate any info, maybe a water pump? I’ll have to look into it
 
1 - 3 of 3 Posts
Top