Honda CBR 600RR Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
380 Posts
Discussion Starter #1
I went to bolt my right side passenger peg back on last night and one of the bolts started to cross thread, now it won't start threading straight. I looked at the female threads and there are some metal shavings, and you can see were they are a bit stripped, maybe the first 1/4 of the threads, what do I do?
 

·
Registered
Joined
·
7,432 Posts
Get a tap with the same thread size and Pitch and re tap it from the back side, this way you can correct the stripped threads in the front.. (as it sounds like you only skrewed up the first few. the threads in the back should still be plenty good enough to hold the peg as it is supposed to)

pretty easy fix, and only the cost of a tap.

(this is all based on the fact that I think thethreads go all the way through the subframe - 90% sure)
 

·
Registered
Joined
·
380 Posts
Discussion Starter #4
No they don't go all the way through. I guess a tap is probably the only way this will work out though.
 

·
Registered
Joined
·
7,432 Posts
Yep try and tap it with the same thread size and pitch first and hopefully everything lines up with the unstripped threads ... other wise you will need to drill and tap with a bigger size and get a new bolt to fit.. and if all else fails you can find a subframe on ebay from $100-$200
 

·
Registered
Joined
·
112 Posts
Clean the threads with a tap. If that doesn't work you will need to use a thread repair kit. The kit should come with a larger tap and a threaded insert.
 
1 - 6 of 6 Posts
Top