Honda CBR 600RR Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Just got a new to me CBR600rr, and I'm having a problem with it. As the title says it turns off at stop lights. I can ride without issue, but sometimes it will just cut at stoplights. Usually it will turn on right away, I've had it once where it wouldn't turn on for about 5 minutes. Initially I had some issues starting it after using the kill switch, but after contacting the previous owner he says that using the kill switch will make the bike not start for a couple hours (already looking into cleaning that). But I do not think it's the kill switch that is turning it off when I stop, because you'd think it would happen while moving as well. I will do my best to answer any questions about the bike. Any advice is welcomed!
 

·
Registered
Joined
·
1,008 Posts
There are just way too many possibilities. Maybe you can help us narrow it down by checking and answering these:

1. What year is the bike and what's its mileage?
2. Do you get any error code (FI) while the engine is running? If yes, what is it?
3. Does it run unusually hot? Does it smell lean? rich?
3. Does it happen if you crank it up and just let it idle for a while?
4. What can you tell us about the history of the bike? last time air filter cleaned/changed? Any work in the fuel system? Exhaust system? Electrical? Any recent spills/crashes?
5. Did this just started happening? or was it after some particular work done on the bike?

Any details can help...
 

·
Registered
Joined
·
2,483 Posts
It’s not uncommon to have problems with the 03-06 (assuming yours is within those years) right control cuz the throttle housing and tube iare together with the kill switch and start button (constant on/off throttle). To fix it, you either get a replacement part (new or used) or resolder the wires.
 

·
Registered
Joined
·
39 Posts
Not an expert but you gave a poor description of your problem. Thus hard to tell what could be wrong. Does the bike idle fine at cold start? Does it idle fine after it has warmed up? If not, did you adjust the idle with idle cable. How long before it actually dies or is it completely random. Does the bike seem like it's making a hesitant stall or is it an instant stall? I personally would start by checking for coolant level, exhaust leaks, poor fuel pressure from pump or a rare case of bad throttle adjustment by the fuel rails, right below intake manifold and ecu. You will need to do a lot of troubleshooting work unless you have specific FI codes or more specific symptoms. If by any chance you live in Chicago Area, send me a message.
 

·
Registered
CRB600RR 2004 US SPEC
Joined
·
15 Posts
Had the same issue on mine... its the ignition coils or bobbins as they're called here in france... if it's been fitted with bad sparks at some point the coils get damaged and then the cylinders don't all fire so you stall when she gets hot at the lights...
 
1 - 5 of 5 Posts
Top