Honda CBR 600RR Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I just recently bought a new fairing kit and am having a hell of a time getting things to fit right. The biggest one of them all is the one shown in the picture. The sides dont come together and clip into the gas tank so there is a big gap. Does anyone know how to fix (besides buying a better fairing set) or have had problems like this one? Any help is appreciated. Thanks.
 

Attachments

·
Registered
Joined
·
187 Posts
Will they clip together when you push them together, then pop out when you let go? Or do they not clip together period. IF they pop out after you let go, id pull it all off and just double and triple check where hoses and crap are at. I had the same issue with my stock fairings not wanting to go back on when I replaced my gas tank. I pulled it apart twice before noticing some hoses had moved and were stopping the right side from going back together. If they wont go together at all, could be the same issue, or you could have got a bad set from the Manuf.
 

·
Registered
Joined
·
276 Posts
mine does this but the tabs are broken on the left side. i noticed that my bracket was bent that connected the upper mid and mids together (with a bolt) so i bent it back and the fairing where you are having fiment issues sits right into place. so if its been downed i suggest checking that.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
I tried bending the brackets thinking that was the deal but that did not seem to fix the problem. The gap is just so big that I cant even get the fairings to clip together. I tried moving hoses out of the way and wiring but its not enough to give it the distance. I just thought I might be missing something but have a feeling I got a shitty set of fairings. Guess I am just going to have to live with it cause I doubt they will take them back with scratches and chips in it now. What are a good set of fairings so I dont make this mistake again???? Another freaking dent in the bank account.
 

·
Registered
Joined
·
276 Posts
check out your OEM fairings. like side by side and compare, take measurements between holes, sizing etc and be positive that its not a size or quality issue. i havent really heard of anyone with this severe of a problem, but then again, my signal wires ALWAYS get in the way when putting my fairings back on, double check you have them routed correctly when you have the fairings up. has the bike been downed? try putting those on FIRST then attach the mid mids and lowers.

umm, try kpowersports.com pretty cheap and he has some fairings already in the US (somewhere in FLA) so shipping will be quick depending on which you buy. good luck none the less.
 
1 - 5 of 5 Posts
Top