Honda CBR 600RR Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
368 Posts
Discussion Starter #1
Hey,

First off, I have used search.

I have a PC3 installed, and I have checked all my connections; they all seem good. The bike runs fine, except that it WILL NOT rev past 12,500- which almost leads me to believe there is a problem with the fuel (either the pump, or the upper injectors).

I'm running Road Atlanta come Friday. Please help me out and suggest things that I may have missed.

Best,
Garrison
 

·
Administrator
Joined
·
51,153 Posts
Take the PC3 off ride the bike and see if its any different if its acts the same then its not the PC3
if its rides better and the light goes away then its the PC3
 

·
Registered
Joined
·
368 Posts
Discussion Starter #3
I went ahead and pulled out everything, then put it together meticulously. The bike will now rev past 12,500 (beautifully, in fact), but the light is still on. Also, I learned I do not have a MAP sensor, nor do I know what one does.

Anyway, if it'll run I'm fine with that. Race bikes and OEM ECM's can't be expected to always get along.
 
D

·
Guest
Joined
·
0 Posts
You need a MAP sensor for the bike to run right. It detects the vacuum at the intake manifold. Without one, it will set a DTC and the bike will run in limp mode to prevent any damage to the bike since the MAP sensor is valuable for the a/f ratio.
 

·
Registered
Joined
·
29 Posts
the little fuel icon on the dash coming on when u turn the bike on is normal, since the engine isnt running there is no oil pressure, put it in neutral and have the kick stand down and watch the MIL light(the light that is red) and it should blink, count the blinks and watch for how long the blinks are and ref. to your manual for the condition. if it doesnt blink or anything you're gonna have to take it to your local dealership and have them run it on a HDS to link up to the ECM, and if you don't have a map sensor order one or your bike will just use the last known altitude map
 
D

·
Guest
Joined
·
0 Posts
the little fuel icon on the dash coming on when u turn the bike on is normal, since the engine isnt running there is no oil pressure, put it in neutral and have the kick stand down and watch the MIL light(the light that is red) and it should blink, count the blinks and watch for how long the blinks are and ref. to your manual for the condition. if it doesnt blink or anything you're gonna have to take it to your local dealership and have them run it on a HDS to link up to the ECM, and if you don't have a map sensor order one or your bike will just use the last known altitude map
There are no stored altitude maps in the ECU. There is only a limp mode which severely retards the engine performance to prevent more damage internally if any.
 
1 - 6 of 6 Posts
Top