Honda CBR 600RR Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter #1
Hey guys, I bought this..

http://www.ebay.com/itm/121187703534?ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1497.l2648

(I have hazard lights so I needed the 4 pin relay - not the 2 pin)

I had LED's on the rear and the stock ones on the front. The relay arrived yesterday, I fitted it and it worked fine (meaning that all four indicators were flashing correctly).

However tonight I fitted LED's on the front too and now all indicators are flashing quick again. Is there something I am doing wrong or is this relay thing faulty?. Is there an easy way to test it?.

Thanks!.
 

·
Registered
Joined
·
131 Posts
Hey guys, I bought this..

http://www.ebay.com/itm/121187703534?ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1497.l2648

(I have hazard lights so I needed the 4 pin relay - not the 2 pin)

I had LED's on the rear and the stock ones on the front. The relay arrived yesterday, I fitted it and it worked fine (meaning that all four indicators were flashing correctly).

However tonight I fitted LED's on the front too and now all indicators are flashing quick again. Is there something I am doing wrong or is this relay thing faulty?. Is there an easy way to test it?.

Thanks!.
If it worked fine with leds on the rear then it should work fine after fitting the front leds...
Get tst industries or custom led flasher relay. I never heard of any problems with those 2
 

·
Registered
Joined
·
49 Posts
Discussion Starter #7 (Edited)
So I contacted the seller who I bought the flasher relay off. He agrees to send me a replacement relay. It arrived in the post this morning so I take the old one out.. put the new one in and it doesn't work either! (indicators just keep flashing quickly). It is in fully because if I take it out completely and start the bike then the indicators don't work at all.

Is there something I am doing wrong here or is this just plain bad luck from a bad bach at the store? I can't use the relay from TST industries because I need the 4 pin connector as my bike has hazard lights. Does anybody have any ideas of where else to get hold of these relays?.

Thanks
 

·
Premium Member
Joined
·
13,137 Posts
It will be the burnt out bulb function of the relay letting you know that an indicator is out... it just can't tell the difference between a blown globe and LEDs.

Throw a resistor in parallel and your problem should go away.
 
1 - 10 of 10 Posts
Top