Honda CBR 600RR Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
1,244 Posts
Discussion Starter #1
Well my whip is a 96 explorer sport. My problem is when i turn on the car my rear running lights or brake lights dont work.
I have no lights on whatsoever back there. My immediate thought is that it was a fuse. Checked all the fuses and none were
burnt out. I am pretty much so car illiterate but maybe someone could give some advice on what I can check for. I hate
to pay a shop a couple hundred bucks to do sometyhing that im sure is simple. any help is much appreciated....
 

·
Registered
Joined
·
336 Posts
So both your running lights and brake lights don't work? I fixed a Ford Explorer before with a brake light problem that turned out to be a brake light relay. You probably tried this already, but have you checked the bulb? You might want to start by checking if there is power going to the bulbs first and work your way back.
 

·
Registered
Joined
·
1,244 Posts
Discussion Starter #4
Too_Funny said:
So both your running lights and brake lights don't work? I fixed a Ford Explorer before with a brake light problem that turned out to be a brake light relay. You probably tried this already, but have you checked the bulb? You might want to start by checking if there is power going to the bulbs first and work your way back.
Yep there is power going to the bulbs. And the turn signals are working, I guess its just the brake lights that are out. I had a buddy start tearing it apart and he tested everything and said the same thing about the brake light relay. He said hes pretty sure thats what it is. Is this a hard thing to fix?
 

·
Registered
Joined
·
94 Posts
Gernade

My buddy in VA had an explorer and all I ever heard was "I'm going to blow that POS up". He hated it because everyday it had something new wrong with it. If you got the cash, junk it and buy something else. IMO

Hope you figure it out!
 

·
Registered
Joined
·
1,244 Posts
Discussion Starter #6
Screamin' R said:
My buddy in VA had an explorer and all I ever heard was "I'm going to blow that POS up". He hated it because everyday it had something new wrong with it. If you got the cash, junk it and buy something else. IMO

Hope you figure it out!
ok, well i dont have the cash.....NEXT
 

·
Registered
Joined
·
336 Posts
Its just a relay. Very simple to replace, but first you need to locate it. Usually if you go to the dealership and buy it, ask them to pull it up on their computers and they can show you where it is.
 

·
Registered
Joined
·
1,244 Posts
Discussion Starter #10
What did you have to/where do you locate a bad ground? Im kinda a moron when it comes to vehicles...........
 
1 - 10 of 10 Posts
Top