Honda CBR 600RR Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
773 Posts
Discussion Starter · #1 ·
so I took off my front tire today, and while it was off I accidently pull the front brake.

When putting the front tire back on, I opened up the brake pads with a screwdriver put the tire back on.

Now when using the front brake it seems like it takes more to engage the front brake. I have to pull it halfway in about for it to grab good. It is on setting #1 also. When I put it on #6 the brake lever pulls all the way to the clipon pretty much very easily.

Just wondering what I need to check. Quit the front brake pads be getting low?
 

·
Registered
Joined
·
166 Posts
You may have pushed dirt behind the dust seals on the pistons. First try bleeding the brakes. Second, clean the pistons with brake cleaner and q-tips. If you still have issues, you'll probably need to rebuild the calipers.
 

·
Registered
Joined
·
28,565 Posts
why did you use a screwdriver? its not hard to push the pistons
in. take out the pads and use your fingers and squeeze in the pistons.
then put the pads back on.
either way i think its all in your head bro! have you ridden the bike since
then? or are you just squeezing it out while its parked? go ride it and test
out the brake power/feel.
as for the 1-6 clicker....its not a meant for gauging the brake lever. its merely
a comfort option for people with small or large hands. extends or retracts the
lever for different size hands....closer or farther.
 
1 - 3 of 3 Posts
Top