Honda CBR 600RR Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
Got the bike last September and every time I fill it up all the way, the fuel indicator bars don't go all the way to the top...probably missing 3-4bars.

Could this be wiring issue or the fuel pump?
 

·
Registered
Joined
·
2,049 Posts
Got the bike last September and every time I fill it up all the way, the fuel indicator bars don't go all the way to the top...probably missing 3-4bars.

Could this be wiring issue or the fuel pump?
Could be a wiring issue, metering issue on the instruments or it most likely will be the fuel level sending unit which is nothing more than a float, arm and potentiometer hooked up to the fuel pump assembly.

Couple questions:

1. Year and model of bike? We all assume 600rr but on here who knows.

2. Any work done to it? I.e. Have you recently replaced the fuel pump, gas tank or have done work in that area?

3. Does it register below what you are saying? In other words, does it work for below a half tank or dies it not work at all.

4. Has it ever worked since you have had the bike?

My guess is the float is stuck and simply emptying the tank, pulling the pump assembly and working the mech up and down will fix it. Or you'll see an issue that would need to be addressed. If it operates correctly follow the instructions in your service manual for what the sending unit should read in ohms.

Check your under the tank for wiring issues: bent pins, pinched wires, etc. as well. That should get you going.

Mike
 
1 - 3 of 3 Posts
Top