Honda CBR 600RR Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter #1
For some reason my fuel pump will not come on. Started right up driving down the road bike just shut off and wouldn't come back on. Checked all wiring and relays.. I dont know what it could be. i dropped it off at the shop but hes still looking and i have laconia bike week in nh to go to. Horrible timing for this to happen. Any info is greatly appreciated . Its an 03 6ooRR. Thanks everyone
 

·
Registered
Joined
·
8 Posts
I am having same problem, Fuel pump doesn,t work. Changed ECM, realy, wiring harness.... fuel pump will prime when grounded by it self, from what i've heard the ecm controls the ground but I have changed and it still doesn't work. I also have the FI light on. It stays on and solid when I turn on bike and kill switch
 

·
Premium Member
Joined
·
13,137 Posts
As stated, check the ground circuit for the engine stop relay... the BAS is the only thing on it...
 

·
Registered
Joined
·
8 Posts
First I would like to thank everyone for their help. For me it was the ignition switch that was changed. For those of you who don't know the 03-04 ignition switches have a resistor the changes the 12V from the battey and turns it into 9V to trigger the fuel pump to prime. What I did was hook my meter to the pink wire that was coming out of the ignition switch and when the bike was on it had 12V not 9V like it should. I then hooked up a 9V battery to the pink wire on the bike side where it should connect to the pink on the ignition switch. Turned on the bike and it fired right up. There are two things you could do add a resistor or buy a new ignition switch but MAKE SURE ITS FOR A 03-04 and has the resistor.
 

·
Premium Member
Joined
·
13,137 Posts
Its not a resistor... its a 3V zener diode, hook it up reverse bias so that the anode connects to the pink wire.
 
1 - 7 of 7 Posts
Top