Honda CBR 600RR Forum banner

Status
Not open for further replies.
1 - 2 of 2 Posts

·
Registered
Joined
·
1,008 Posts
Discussion Starter #1 (Edited)
hi all!!
I need little help deciding whether my mechanic is bullshitting me...I sent my bike for service (radiator, injectors ... etc) and cat delete and now it wont start... its worth mentioning that I have a hacked ECU from back when I lost my key (some of u might remember), I also have BAS byBASsed and have been having an electrical issue where the fuel pump wont prime say once in every 10 starts, I'd then just take the bars from lock to lock and shake it a few times and then it'll prime... now with the service done, my mechanic says it wont start at all! he says he tried everything and then he noticed the cracked ECU case and and told me its because the ECU is hacked, now all it needs is to be reprogrammed, since "you cannot simply disconnect a hacked ECU from the loom!'', i then gave the second key as he asked, and i am now just waiting for his call, thinking he pissed all over my face with that story, is there any legitimacy to this??????...

i have stressed the electrical issue several times to him and i still think its a loose pin, connector, ground or just a relay/component due for replacement.. but he keeps ignoring my theories...what do you guyz think?

p.s. the bike also has a history of maintenance negligence and high mileage, and has shown me the check engine light (not FI) a couple of times towards the end of january
 

·
Registered
Joined
·
13 Posts
Should have never told him about "hacked" part, now he's using it as en excuse. If it worked when you dropped it off, it should work when you pick it up. Make him responsible for it unless he was working for free.



Sent from Motorcycle.com Free App
 
1 - 2 of 2 Posts
Status
Not open for further replies.
Top