Honda CBR 600RR Forum banner

Status
Not open for further replies.
1 - 10 of 10 Posts

·
Registered
Joined
·
621 Posts
Discussion Starter #1 (Edited)
***Help: 05 600RR won't start (BAS was upside down!)***

*****************************HELP***************************


I have a 05 600RR about about a month now. The bike started up fine and rode perfect when I purchased it . It had a PCIII, Micron slip on and K&N air filter. Since I like my bike stock, I traded my PCIII, mircron pipe and K&N filter to my buddy for all his stock parts. Now, I finally had the chance to ride my bike after all my finals. Bad news, the bike won't start. The fuel pump won't engage when I turn on the kill switch.

I double check the BAS control, try out two different fuel pump, check all fuses, and check all connectors. The fuel pump is still not working. The battery is perfect and the bike does cranks. What is the problem?


EDIT: problem solved. BAS was upside down.



thanks.
 

·
Registered
Joined
·
1,821 Posts
Check your FI fuse under the seat if it's blown. Mine blew out and the bike wouldn't start anymore but keep cranking. I put a new fuse in, key to on, FI primed/hummed, hit start and that fuse blew out in front of my eyes. Culprit=Fried a hole into my ignition coil, New coil+wireharness under warranty. Good luck, hope its a smaller problem than mine was.

 

·
Registered
Joined
·
621 Posts
Discussion Starter #4
The FI fuse is fine. I took all the aftermarket parts off and left the bike alone. Finally had time to put on the all the stock parts.
 

·
Registered
Joined
·
621 Posts
Discussion Starter #6
well, if there was an issue on the ignition switch, will the gauge come on? or will the start button work?
 
1 - 10 of 10 Posts
Status
Not open for further replies.
Top