Honda CBR 600RR Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
ok i have an 07 cbr600rr. i took it out for a ride and when i got my destination i hit the kill switch and a second later when i tried to start it back up it wouldnt. i think it might be the r/r. I have 12,xxx miles on it. Any answer why it wouldnt start?
 

·
Registered
Joined
·
22 Posts
Discussion Starter #3
Yea i put it back in the run position. when i put it in the run position i didnt hear that like winding sound it always makes.
 

·
*BOTM Feb '11, Mar '12*
Joined
·
23,598 Posts
That noise is the fuel pump priming, don't know what could have disconnected that from just hitting the kill switch
 

·
Street BOTM Winner 10/11
Joined
·
4,320 Posts
is the batt. fully charged? did you check the fuses? and whats an r/r?
 

·
Registered
Joined
·
1,799 Posts
Does it turn over with the same speed/sound as before? If not, its probably the battery. There have been a number of guys with crapped out batteries on the '07/08. Otherwise the next easiest thing is to check fuses and the kick stand switch.
 

·
Street BOTM Winner 10/11
Joined
·
4,320 Posts
it might be, when my bike was dead it was just the batt. now that its good again i got it on a battery float.
 

·
Registered
Joined
·
1,453 Posts
noob question, but whats that?
it rectifies and regulates the current coming from the alternator, keeping it even(or almost even) when the revs go up (instead of sharply shooting up). so, it keeps all electrical components from getting fried.
 

·
Street BOTM Winner 10/11
Joined
·
4,320 Posts
it rectifies and regulates the current coming from the alternator, keeping it even(or almost even) when the revs go up (instead of sharply shooting up). so, it keeps all electrical components from getting fried.
oic. thank you.
 
1 - 14 of 14 Posts
Top