Honda CBR 600RR Forum banner

1 - 20 of 39 Posts

·
Registered
Joined
·
220 Posts
Discussion Starter #1 (Edited)
I installed the ecm from an 08 bike in order to get back my power which is lost on the 09. However after the bike starts, I get code 25 which the SM states is a knock sensor problem. I know I didn't go anywhere near the sensor so I don't know if this was just a stored code in the 08 ecu that was never cleared or what...I'm about to go back and try to clear the code with a jumper wire the DTC connector and see if the code flashes again. If that doesn't solve the problem, then I'm thinking it may be a bad ECM as I just started the bike with the 09 ECM right before taking her apart just to make sure everthing worked ok and no light. I will know if it's a problem with the 08 ECM if I connect the 09 ECM back and the FI light goes away. This is a non CA bike.

Ok, I just came back from clearing the MIL code. Switched back the 09 ECU and no code. Put in 08 ECU and code 25 again.

Any other ideas?

P.S
I hate 09 fairings
 

·
Registered
Joined
·
541 Posts
Try another 07/08 ecm.. sounds like you got a dud ecm.
 

·
Registered
Joined
·
220 Posts
Discussion Starter #3
Damn. Not good...gotta deal with shipping and all that..but if that'll fix the problem then here we go...
 

·
Premium Member
Joined
·
13,137 Posts
Don't know if your still having this same problem, but another bloke is and pointed me at your thread as well...

Here is your answer:


Just looked it up for you and the knock sensor is wired differently...

A = Black connector
B = Light Grey connector

09:
Blue - B21
Blue/Yellow - B23
Yellow/Red - A9

08:
Blue - B21
Blue/Yellow - B5
Yellow/Red - A9

So wire it up the way it should be for an 08 ECU and you will be good to go!
 

·
Registered
Joined
·
220 Posts
Discussion Starter #5
Nico,

thanks for the info. Not really sure how to use it as I'm not as mechnically inclined as I'd like to be. :(








Don't know if your still having this same problem, but another bloke is and pointed me at your thread as well...

Here is your answer:
 

·
Premium Member
Joined
·
13,137 Posts
Have a look at your light grey ecu plug, you just need to move the wire that is in pin 23 to pin 5, or if you have a decent bike shop they should be able to do it for you.
 

·
Registered
Joined
·
220 Posts
Discussion Starter #7
Ok I can do that. Now what happens to the wire that is currently in pin 5? If there is one? I don't have the plug in front of me at this point. But I DO appreciate the help!!! I just rec'd a servo dummy plug that should help me lighten the bike some as well. So I'm exceited that I can finally get my lost HP back.
 

·
Premium Member
Joined
·
13,137 Posts
You shouldn't be loosing any hp by having the dtc set, and there shouldn't be anything in pin 5 as far as I can tell...
 

·
Registered
Joined
·
220 Posts
Discussion Starter #9
I meant excited at the prospect of getting the 08 ecu finally working with my 09 bike due to your help :) I was wanting to do it in the 1st place to get back the lost HP that the 09 ecu had by replacing it with the 08 ecu. While I was at it, I had just bought servo plug to remove my exhaust servo motor and cables. Once I've conquered that, I was wanting to go into the airbox a bit. I think I also read something about a pair valve.
 

·
Registered
Joined
·
220 Posts
Discussion Starter #10 (Edited)
You shouldn't be loosing any hp by having the dtc set, and there shouldn't be anything in pin 5 as far as I can tell...
Need quick help. Looking at grey connector, I can't tell which one is Pin 23. I know u mentioned blue/yellow wire but when trying to count the pins it doesn't count right. What color is pin #1? When trying to count from either side neither one equals pin 23 with blue yellow wire. If a solid blue wire is Pin 21, then pic 23 is black and yellow.
 

·
Registered
Joined
·
7,432 Posts
How much did you pay for the ecu?
 

·
Registered
Joined
·
220 Posts
Discussion Starter #13 (Edited)
I got it from ebay from a place that sells used parts and I think I paid 60 plus shipping. Any how, see pics below and please advise.
 

·
Registered
Joined
·
220 Posts
Discussion Starter #15 (Edited)
The solid blue one I believe was mentioned above to be B21. Can anyone tell me if you count across with the top left being #1 or if you count down by columns?

 

·
Premium Member
Joined
·
13,137 Posts
This is the ECU side of the male connector....



Or in other words, take the wire in the circle and put it where the arrow is pointing...
(and yep, I realise that its black/yellow... that is my fault - misinterpreted Bl for Bu in the book)

 
1 - 20 of 39 Posts
Top