Honda CBR 600RR Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
342 Posts
Discussion Starter #1
Hi all, I'm new to the forum. I bought my 2008 cbr600rr about 10 days ago. It's since been back in the shop for some pre-existing electrical issues but I'm curious about one thing in particular.

When I turn off the ignition key and turn it back on it resets my trip odometers and the clock. Is this normal?

The bike is stock except for flush mount turn signals and a fender delete. 3500 miles
 

·
Registered
Joined
·
3,336 Posts
no this isn't normal. sounds like you got a ground issue or a short. definitely get it checked out for sure
 

·
Administrator
Joined
·
51,151 Posts
One of the battery cables might be loose
 

·
Registered
Joined
·
342 Posts
Discussion Starter #4
The bike is back from the shop with everything fixed except for the key issue. They were not able to figure out what was going on and said it might need to go see the Honda dealer. Just wondering if anyone with an 07/08 600RR has had this problem?
 

·
Registered
Joined
·
903 Posts
It is definitely NOT normal. The trip and clock only reset when the battery is disconnected......and maybe not even the trip. Sounds like maybe someone has been doing some wiring mods to the bike and they don't have a clue what they are doing!
 

·
Registered
Joined
·
342 Posts
Discussion Starter #7
Here's the latest. The dealer I bought the bike from said they've talked to Honda and they attributing the malfunction to a "common problem among 2007 and 2008 600's and 1000's." According to them Honda has not yet taken action on this issue. If this is true then I find it hard to believe that there aren't any other members here who have experienced the same problem. But I haven't found anything related while searching the forum.
 

·
Registered
Joined
·
173 Posts
It is pretty simple. The cluster is loosing battery voltage with key off or the cluster itself is bad. Check the fuses listed above. If they are ok then for voltage at the cluster connector with key off. Use a volt meter between the + W/G and - G/Bl with the connector plugged in. If you have voltage then the problem is in the cluster if not then you have a wiring problem. Most likely and open on the W/G wire. Like dcope said get a wiring diagram.
 

·
Registered
Joined
·
342 Posts
Discussion Starter #10
If anyone wanted closure to this problem... I ended up taking it to the Honda dealer in town and they fixed it up for less than $300. But they said that the wiring was pretty messed up and the fault was due to a ground. Turns out the dealer I bought it from really didn't want to fix it. And that wasn't the only thing that was wrong with it. So long story short, don't EVER buy ANYTHING from Fenders Cycle in Des Moines, IA.
 

·
Registered
Joined
·
342 Posts
Discussion Starter #12
Well the fuses could have been blown, but they were blown because some yahoo f-ed up all the wiring when he/she put on the flush mounts and fender delete. The shop manager said wires were crossed everywhere which shorted out all the lights and horn, and grounds were grounded where they weren't supposed to be. Even went so far as to say it was dangerous. The battery didn't even have a strap to secure it (found that out after I had it home from the dealer).

It had apparently been through their "complete inspection" before being sold to me.
 

·
Registered
Joined
·
2,766 Posts
It had apparently been through their "complete inspection" before being sold to me.
Sorry if I missed it but is the dealer fixing all of this under warranty? If not they should be, they sold you a lemon.

edit:


saw your post on closure. Glad you got it fixed. Dealers are nothing but crooks I have come to find out. Safe riding.
 

·
Registered
Joined
·
342 Posts
Discussion Starter #15
Yes, the bike was back at the dealer where I bought it after the weekend was over. They had it for three days and said it was fixed, but it wasn't. I probably should have said take it back but I didn't.

I also found out they were straight up lying to me about it, so i decided to take it somewhere else. I thought the bill was going to be a LOT bigger, and planned on sending it to em, but it wasn't bad.
 
1 - 15 of 15 Posts
Top