Honda CBR 600RR Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
114 Posts
Discussion Starter #1
Hey Guys, So I bought a 08 Honda CBR600RR last season and had Hotbodies Flushmounts installed by the dealer as well as a flasher relay. Now Im gonna be ordering Tripages Standard Clear IT "Brake/Signals", LED Adjustable Tag bracket, and there LED pegs. All of which will be plug n play, now one thing that dawned on me is that Im not sure if they wired my Relay just to my front flushmounts or if it was too all of my blinkers. Anyone able to tell from the pics/vids i have below?






and the YouTube video that shows the blink rate of both the front/back. If it is, then I have absolutely no problems with the plug n play, from all of Tripages stuff, otherwise Im gonna have to figure a way to install another relay for the tail section...



Thanks Guys!
 

·
Registered
Joined
·
114 Posts
Discussion Starter #3 (Edited)
what a dawn you had, I believe your relay is wired wrong.
It's flashing pretty fast.
Well if its wired into the stock rear light assembly as well as the front flushmounts then i would think the rear would flash faster, which is not a big deal since im replacing the rear section. So I guess this means that I've answered my own question? If the relay wasnt working then the front would flash a lot faster!! (almost solid?) It should be correct since I paid a dealership to do it!!
 

·
Registered
Joined
·
302 Posts
probably a bad relay. its plug and play you cant really fudge it up... From the vid its plugged in correctly. all your signals are blinking too fast -- only real thing it could be is a bad relay, although uncommon i've seen a couple threads on here with bad relay issues
 

·
Premium Member
Joined
·
14,330 Posts
That is your stock flasher relay, they didn't do anything to it. Just installed you front signals. So if they charged you for a flasher relay you need to avoid that place doing any more work on your bike. The flasher relay is plug n play and comes with the complete package, and what you shined your light on is the flasher relay. 2 seconds to swap out for an led one that will return your signals to stock rate. The flasher relay controls all signals front and rear. There is only one of them. T
 

·
Registered
Joined
·
114 Posts
Discussion Starter #8 (Edited)
Hmm well I paid like 20 bucks at the time for the relay so I better check my bill to see if they charged me for it.

Edit:
Just Checked, ya it was $19.50 and they called it a "Load Equalizer F/Mech F" and I purchased it with a Honda Tank protector. (Both had to be ordered and was installed before I pickup up the bike from the dealer, I had to remind them about the Tank protector I purchased)

Install work order says install Flushmounts, says nothing about the relay or load equalizer and the price was never refunded. Guess I better go back to the dealer with the receipt!!
 

·
Premium Member
Joined
·
14,330 Posts
What you have pictured is your flasher relay, that's stock. Unless they put the load equalizers up front with the signals, if they did they don't work because that is a fast flash rate. Also the flasher relay is plug n play and cheaper/easier than wiring in load resistors. T
 

·
Registered
Joined
·
114 Posts
Discussion Starter #10
Ya I asked for a relay and thats what I ordered. If they did install the "load equalizers" what would happen if I installed the relay? and where would they mount them (I wanna go look)

Thanks for you help T
 

·
Premium Member
Joined
·
14,330 Posts
Ya I asked for a relay and thats what I ordered. If they did install the "load equalizers" what would happen if I installed the relay? and where would they mount them (I wanna go look)

Thanks for you help T
Remove one of the fairings for your signals and see if there is anything extra in there. Would be a long rectangle.. You don't have to do it, though just take your bike and turn on the signals and go to a stock bike and turn on the signals. show the speed difference. T
 
1 - 14 of 14 Posts
Top