Honda CBR 600RR Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
856 Posts
Discussion Starter #1
04 CBR - 10k miles and my horn sounds awful. It beeps once and then just sounds like its roasted. Coming home tonight from class it didn't even work at all. I do alot of highway communting and stuff. Not really sure what the problem is, the bike fired right up this morning.

Any ideas whats up?
 

·
Registered
Joined
·
856 Posts
Discussion Starter #2
My dash, headlights, and signals both front and rear work fine. Not really sure if its a battery or fuse problem?

The horn itself sounds like its the issue :\. Sounds awful. Just went outside to check the signals and pressed the horn and it just squeaked..
 

·
Premium Member
Joined
·
14,330 Posts
Check the wires... Wheelies and rough roads can cause a loose connection or dirty connection..
 

·
Registered
Joined
·
856 Posts
Discussion Starter #4
tripage said:
Check the wires... Wheelies and rough roads can cause a loose connection or dirty connection..
Ok I went and tugged on each of the two connectors on the horn and the bottom black wire just fell right out. So I took off it off and stripped it and touched it to the metal piece and the horn works great.

But I need to figure out how to attach it back to the metal piece since there is a piece of the wire still stuck in it?

Any ideas on how to open this little thing back up, or pick up another one?
 

·
Premium Member
Joined
·
14,330 Posts

·
Registered
Joined
·
856 Posts
Discussion Starter #6
Yep just dug through my connectors box and found one almost similar to the one that was on there. But I can't fit the little rubber protector thing over the top of it, think it should be alright?
 

·
Registered
Joined
·
1,970 Posts
The same thing just happened to me last week. Same wire. You can buy the spade connectors that have the rubber protector on it already. I had some from 10 yrs ago that I held on to and sure enough I ended up needing them.
 

·
Registered
Joined
·
856 Posts
Discussion Starter #9
Cool thanks Tripage for the quick help - everything looks like its gravy now.

Appreciate the fast responces guys.
 
1 - 9 of 9 Posts
Top