Honda CBR 600RR Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
75 Posts
Discussion Starter #1
Hi guys, bike is an 03 600RR.

i have done a search, but the information is everywhere. lots of unsolved posts etc

So here is my problem, please help if you can.

Riding along and the bike's oil light came on and stayed on.
Oil was not low but not full, so i topped it up to the top of the sight glass. Made no difference.

Now the light did flash but i didn't realise that this was a code, at the moment the bike is sitting without oil and filter as i am going to change them tomorrow.

The bike is also fitted with a power commander and i did set the TPS earlier on before the ride out. I have also changed the air filter recently.

So guys any suggestions would be 110% appreciated. Thanks
 

·
Registered
Joined
·
363 Posts
Sounds to me like the oil pressure sensor took a crap, or wiring in between it and it's controller (ECU?) They are fairly easy to replace (at least on my 599) If you dig through the parts breakdown in bikebandit.com you could find it. Not sure how much they go for. Good luck!

Also, flashing oil light was not a code, it's only the FI light flashing that's a code.
 

·
Registered
Joined
·
75 Posts
Discussion Starter #5
What oil are you using? Did you change it up recently?
Oil hasnt been changed for a while, or has the filter. I drained the oil and it was pretty thin. Using silkolene comp 4 semi-synthetic oil.

Thanks
 

·
Registered
Joined
·
75 Posts
Discussion Starter #6
Sounds to me like the oil pressure sensor took a crap, or wiring in between it and it's controller (ECU?) They are fairly easy to replace (at least on my 599) If you dig through the parts breakdown in bikebandit.com you could find it. Not sure how much they go for. Good luck!

Also, flashing oil light was not a code, it's only the FI light flashing that's a code.
The oil light is 100% not a code? Ill look into the pressure sensor, going to try get a lend of a pressure tester.
 

·
Registered
Joined
·
363 Posts
Oil light is 100% not a code, only FI light.
 

·
Registered
Joined
·
75 Posts
Discussion Starter #8
Oil light is 100% not a code, only FI light.
Thank you for clearing that up. That makes it a bit easier now.

Possible faults then,

- Oil and filter
- Oil pressure switch
- Oil pump

If anyone can add then please do, thanks
 
D

·
Guest
Joined
·
0 Posts
Failures would be a drop in oil pressure, such as a pump not working right (you'd have heating problems), too little oil, too much oil, or the sensor is bad.
 

·
Registered
Joined
·
75 Posts
Discussion Starter #10
Solved.

Changed the oil and filter and it went out straight away. Dont know what i was worried about, its a Honda. :cruising:
 

·
Registered
Joined
·
363 Posts
I love easy and cheap fixes, glad all is well!
 
1 - 12 of 12 Posts
Top