Honda CBR 600RR Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
I had a question that maybe you would know the answer to. I bought a 03 600 rr with 12k miles. The oil light stays on anytime key is on or the bike is running. It looks like someone tried to cover the red light with black tape. The oil pressure icon under the mileage on the LCD is also always on. The oil was thinner than I thought it should be, and it smelled like gas. The bike runs and sounds normal. No smoke from the exhaust. I've checked the oil pressure and it's good. And I've changed the oil and replaced the filter. I put a voltmeter to the oil pressure switch and I didn't get anything. Don't know if that means if switch is bad, or short in wiring. What is my next step to check? How do I check the switch. And does someone have a link to the post to checking the wiring. Any advice or ideas would greatly help. Thank you for your help.
 

·
Registered
Joined
·
8 Posts
I have the same issue my light blinks then goes solid red. I took it to a shop and they replaced the sub harness and the problem went away for a few hours then the problem came back. They cleaned the ecu of any error codes. What could this possibly be.
 

·
Registered
Joined
·
69 Posts
I have the same issue my light blinks then goes solid red. I took it to a shop and they replaced the sub harness and the problem went away for a few hours then the problem came back. They cleaned the ecu of any error codes. What could this possibly be.
You need to know the DTC Diagnostic Trouble Code your bike showing by counting the number of flashes your MIL is showing. For example - MIL will blink twice then blinks three times rapidly then repeats the pattern = code 23 faulty O2 sensor circuit.
Once you figured out the code then you'll be able to figure out your next step.
 
1 - 8 of 8 Posts
Top