Honda CBR 600RR Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi I’m new to bikes and needing help. I have a 2016 cbr600rr. When I turn the bike on (engine not running), all lights turn on and go off. The only one that stays on is the oil pressure. I have check oil levels and they are fine. When I turn the engine on as soon as I release the starter button the bike shuts off. I press the starter button again and then the bike will turn on and oil pressure light turns off. Anyone have any idea what could be wrong?
 

·
Registered
Joined
·
735 Posts
Hi and welcome!

That's correct operation of oil-pressure light (not oil level).
Hi I’m new to bikes and needing help. I have a 2016 cbr600rr. When I turn the bike on (engine not running), all lights turn on and go off. The only one that stays on is the oil pressure.
Oil-preasure light stays on because engine isn't spinning, oil pump isn't spinning and there's no oil-pressure.

I have check oil levels and they are fine. When I turn the engine on as soon as I release the starter button the bike shuts off. I press the starter button again and then the bike will turn on and oil pressure light turns off. Anyone have any idea what could be wrong?
Oil-pressure lights turns off because engine is spinning, oil-pump is spinning and there's oil-pressure.

Oil level is something completely different. There is no oil-level sensor in engine, so you should check oil-level on sight-glass on side of engine before every ride.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Hi and welcome!

That's correct operation of oil-pressure light (not oil level).
Oil-preasure light stays on because engine isn't spinning, oil pump isn't spinning and there's no oil-pressure.

Oil-pressure lights turns off because engine is spinning, oil-pump is spinning and there's oil-pressure.

Oil level is something completely different. There is no oil-level sensor in engine, so you should check oil-level on sight-glass on side of engine before every ride.
Thanks I guess I may be asking the wrong question. I guess Im trying to find out why when I try to start my bike and the oil pressure light is on my bike won’t stay on when I release the starter. ( as soon as I release the starter after I hear the bike has started it shuts off and oil pressure light remains on) I have to press and hold the starter a few times to get the bike to stay on. Once it stays on the oil presser indicator turns off. I have had the bike for a year and it just started doing this.
 

·
Registered
Joined
·
735 Posts
Thanks I guess I may be asking the wrong question. I guess Im trying to find out why when I try to start my bike and the oil pressure light is on my bike won’t stay on when I release the starter. ( as soon as I release the starter after I hear the bike has started it shuts off and oil pressure light remains on) I have to press and hold the starter a few times to get the bike to stay on. Once it stays on the oil presser indicator turns off. I have had the bike for a year and it just started doing this.
OK, let's completely remove oil-pressure light from this issue because it's working properly.

Your problem is bike doesn't stay running when you let off start-button. This is 5-minute fix with multimeter and measuring voltage at various parts of wiring harness. Do you have multimeter and know how to use it to measure voltage and resistance?
 
1 - 6 of 6 Posts
Top