Honda CBR 600RR Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I just got a call back from my local dealership after taking my CBR in for some rough idle and surging. They explained to me that my MAP sensor was faulty and that they suspect the PCIII they sold the bike to me with was the cause of the damage.

Thankfully, they will warranty the repair so I'm out of the woods there, but the tech asked if I'd like to have him return the bike to stock and take the PCIII out. Out of respect for the amount of work the guys undoubtedly put into diagnosing it (and my own inexperience with the PC units) I told him to go ahead and take it off if that was what he thought was best.

My question to you, dotnet, is this: Have you ever heard of the PC units causing this issue? When I get the bike back should I reinstall it? I have an Akrapovic slip on so I've been told a PC is necessary to keep the AF mix right. Should I replace the PCIII with a different unit?

I really appreciate the help!
 

·
Registered
Joined
·
5,228 Posts
had a problem w my 09's pc5.....

showed bad signal/probs with the TPS. (MIL code 8-1 IIRC)

Bike would go into limp mode after some throttle use.

drove me crazy t/s the thing....

removed it and sent it to dj for diagnostic.....it was replaced under warranty.

no harm to ECU.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
I really appreciate your personal reply, DynojetResearch. It sounded kinda screwy to me too, but I'll admit to not being an expert in working on ECU systems.

While you're here, my unit is a PCIII. What advantages do I get by purchasing a PCV unit?
 
1 - 4 of 4 Posts
Top