Honda CBR 600RR Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1 (Edited)
Ok so here's what happens... The bike cruises just fine but it really struggles to go above 12k... If it's NOT under load in nuetral it's just fine, but in first it'll kinda go, in 2nd and 3rd it's a chore.... Reading up on other forums, I'm believing that it's the fuel pump... So I'm wanting to buy the 60 dollar fuel pump with a screen and just "rebuild" my factory fuel pump assembly. Just need advice on this issue... Because I've also read one other forum that said he replaced his fuel pump and it didn't fix anything... I do have 30k miles on my bike, with NO previous maintenance records
 

·
Registered
Joined
·
11,434 Posts
Did you check to make sure your fuel line is in the cut away notch under the tank? Sometimes the fuel line can become kinked or pinched which reduces the pressure.

You can also get a less expensive motor for a rebuild here. But I've never used them.

http://www.ebay.com/itm/111876828786

I'm in the same position right now except my fuel pump completely went out. I'm going to start a thread asking for anyone with experience on these rebuild motors.

Sent from my XT1097 using Tapatalk
 

·
Registered
Joined
·
30 Posts
Discussion Starter #3
Did you check to make sure your fuel line is in the cut away notch under the tank? Sometimes the fuel line can become kinked or pinched which reduces the pressure.

You can also get a less expensive motor for a rebuild here. But I've never used them.

NEW Replacement Fuel Pump Kit w Filter Honda CBR600RR CBR600F4 CBR 600 F4 RR | eBay

I'm in the same position right now except my fuel pump completely went out. I'm going to start a thread asking for anyone with experience on these rebuild motors.

Sent from my XT1097 using Tapatalk
i have not checked that no... a shop put that all back together a couple weeks ago, i would like to imagine that they did that properly but who knows i suppose. like i said its fine until 12k and then its just like a slug... it fights me to climb any higher!
 

·
Registered
Joined
·
11,434 Posts
That's a very common mistake. If they were just servicing the bike, take it back and tell them what's going on. Hopefully they're not trying to pull a fast one by purposely pinching the hose to sell you a $500 fuel pump. It would not hurt to run some Sea-foam through it either.

Sent from my XT1097 using Tapatalk
 

·
Registered
Joined
·
30 Posts
Discussion Starter #5
That's a very common mistake. If they were just servicing the bike, take it back and tell them what's going on. Hopefully they're not trying to pull a fast one by purposely pinching the hose to sell you a $500 fuel pump. It would not hurt to run some Sea-foam through it either.

Sent from my XT1097 using Tapatalk
i currently already have sea foam in it... it hasnt seemed to fix the problem.... so tell me what to look for, im going to take out the fuel pump this weekend just need to know when i lift the tank where to look and how to know if it was kinked?
 

·
Registered
Joined
·
30 Posts
Discussion Starter #7

·
Registered
Joined
·
11,434 Posts
You'll be able to see whether it's in the clamp and out of the groove once you start raising the tank. Just peek under before you raise it up too far.

Sent from my XT1097 using Tapatalk
 

·
Registered
Joined
·
30 Posts
Discussion Starter #10
You'll be able to see whether it's in the clamp and out of the groove once you start raising the tank. Just peek under before you raise it up too far.

Sent from my XT1097 using Tapatalk
ok, ill probably end up doing that on Friday. (work tons of hours haha)
 
1 - 10 of 10 Posts
Top