Honda CBR 600RR Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
Hello all, I have a question...

I removed the lowering bracket easily, but when I tried to slide the front bolt through the frame and bracket, it would not line up. I wiggled everything, adjusted the Jack, even adjusted the rear wheel. Is it possible that my frame is bent?

I can get the bolt through everything but the right side of the frame. The bolt needs to be recessed, but because of the angle, it cannot. Please advise. Thanks
 

·
Premium Member
Joined
·
151 Posts
I'm sure I'll come off sounding like an a$$, especially since I can't offer up a "here's what I did" suggestion, and what I'm about to say seems obvious....

If it's not lining up then there is a good chance that something is either bent, misaligned, or in the wrong place. If you don't have the manual for your particular year, maybe you could pick one up. Or, try putting a request out there and see if anyone is willing to PM you a copy. Might be something in there that will explain what's wrong, or an assembly tip. If you still can't get it put back in place, then I think you're likely looking at something bent.

Good luck!
 

·
Registered
Joined
·
16 Posts
Discussion Starter #4
Thanks crphoenix. You only sounded like an a$$ a little bit. haha

I've got the manual, I've assembled the parts fine, I was just hoping someone would have had this experience and gave me a better answer than the obvious.

I've ordered all new bearings washers, and bolts, so if the new stuff doesn't allign, it's the frame.

*sigh*
 
1 - 4 of 4 Posts
Top