Honda CBR 600RR Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I did a stupid thing and tried to do a burn out and burned the clutch plates. I bought new plates ebc brand and replaced them. couple days later I'm getting a rattling noise from inside the clutch housing I bought a Honda service manual and made sure I put the plates in right I had put the wrong plate in first anyways everything is in right now according to the book. And I'm still getting that rattling noise. I replaced the clutch cable as well thinking that was the problem that didn't work. Any ideas to what it is I'm sure it's coming from the clutch housing it doesn't make any noises when idling just when I rev it up and the rps are coming down it starts to rattle.

Bike specs:
2005 600 RR
13xxx miles
original owner bought it from the dealership when 0 miles I babied it until 3000 miles always kept up with the oil changes I use royal purple max cycle.
 

·
Registered
Joined
·
5,711 Posts
it sounds like a ducati sneaked in to garage last week and Fu(ked you bike and swapped clutches with it. also buying the manual does NOT fix the bike you have to do what it says..hahah JKi feel you pain. try adjusting the clutch cable then maybe pads. if its more metal sounding look at the springs this all could be a simple bolt that needs to be tightened up
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
haha I bought the service manual just to make sure i was putting it in together the right way anyways the noise is really loud I'm going to drain the oil and see maybe something fell and is sitting at the bottom of the pan. other then that I have no clue I adjusting the cable does nothing to it aswell noise wont leave ;( I well recheck the torque specs tomorrow but I'm sure it's not that It engages through all 6 gears smoothly and is rideable just that metal noise vibrating in there.
 

·
Registered
Joined
·
17 Posts
Omg

Same problem, same fix, but now mine has locked up and will not start. It made that ratting noise for three days, then, while idling it just made a tire screeching noise and locked up! Help!!! What can I do? Bike was fine till I changed the clutches.
 

·
Registered
Joined
·
3,513 Posts
Same problem, same fix, but now mine has locked up and will not start. It made that ratting noise for three days, then, while idling it just made a tire screeching noise and locked up! Help!!! What can I do? Bike was fine till I changed the clutches.
 
1 - 5 of 5 Posts
Top