Honda CBR 600RR Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1 (Edited)
2008 CBR600rr.

Yesterday, I do an inspection of the bike as I approach 12,000 miles. So today I start my bike up and it starts out very rough. It was idling around 900 RPM and slowly started to climb up, very lumpy along the way. I turned it off and went to do some research. 20 minutes later, I started it up and everything is running great.

Rewind 1 week. I was riding around and stop at an ATM to get some cash, get back on my bike and it won't start. The starter was working, but the engine wouldn't start. Someone comes over to help, and he said the fuel pump relay wasn't clicking. He leaves and I sit around for a while, and then check the relays again. At first I didn't feel them click, but after turning the ignition on and off a few times, it clicks and the bike starts up. The next day I have trouble starting it again. I realized that if I flick the kill switch on and off 1-3 times it starts up. After 2 days of this it starts back up normally, no problems.

So as of now, the bike is in working order, but obviously something is wrong. What should I be checking?
 

·
Registered
Joined
·
5,226 Posts
have you ever replaced Battery?

Could be that your battery has reached the end of the service life?

also use of kill switch can be a problem....... use search!
 

·
Registered
Joined
·
14 Posts
Discussion Starter #3
The battery was replaced about 4 months ago. It should be fine, all the lights and the starter are strong.

Yes, I have been reading that I shouldn't be using the kill switch! I honestly use it quit a bit. The connections inside the switch seem fine though.
 
1 - 3 of 3 Posts
Top