Honda CBR 600RR Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
526 Posts
Discussion Starter #1
So I was riding back home from school and my bike just kept turning off every minute! I have a 2006rr with 4000 miles, everything is completely stock.
I was gong 60mph on the the freeway and the bike would repeatedly turn off and It would just drop to like 20mph and I would jump started again and again! For 30 miles it must've turned off a total of 20times! I have no idea what the problem is. Any help would be greatly appreciated! Thanks.
 

·
Premium Member
Joined
·
14,330 Posts
Go through the obvious questions first.
You have gas?
Can you hear your fuel pump turn on if you turn the key on and click to the run. Whining prime noise.
Have you taken the bike and just let it idle for a couple of minutes and see if it does anything similar, or is it only under power that it happens?
Check your battery to make sure the power is good. Bikes starts just fine?
T
 

·
Registered
Joined
·
526 Posts
Discussion Starter #3
I have like a quarter of gas left.
I'll go check the rest right now!
Appreciate the help, thanks!
 

·
Registered
Joined
·
1,451 Posts
Would it sputter first or just die? Check the kickstand switch. Maybe its stuck...
 

·
Registered
Joined
·
123 Posts
I would also look in to your regulator rectifier, witch is the little heat sink lookin thing, it holds a charge for your electrical system, kinda like a capacitor for a car stereo.
 

·
Registered
Joined
·
526 Posts
Discussion Starter #8
Yeah, I checked the kickstand switch/cable, battery is fully charged. I'll check the regulator rectifier. Some guy told me that it might be the fuel injection! I'll have it checked out tomorrow!
Thanks for the help guys!
 

·
Premium Member
Joined
·
14,330 Posts
Start the bike and leave it sitting, if the bike turns off in a couple minutes, it's your battery or your fuel pump. Brother had the same problem. Replace the fuel pump. T
 

·
Registered
Joined
·
178 Posts
had a problem sorta like that, had bad cell in the battery, bike only had 1800 miles...but that ended up being my problem..new battery solved it..

just a thought..
 
1 - 10 of 10 Posts
Top