Honda CBR 600RR Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
Hello all,

I have a Scott's Damper that came of my 03 600rr when I bought it. It seems to be working correctly(didn't drive the bike much before the winter came), but i can't seem to adjust it. When I turn the adjustment knob it pretty much just keeps turning in either direction and doesn't seem to click either when I turn it, it never seems to stop turning either. Just wondering if any one has some thoughts on why this would happen. Any help would be greatly appreciated.
 

·
Registered
Joined
·
42 Posts
It needs to be serviced. There is a write up on here(use the search)with the address and phone on where to ship out your Scotts damper. Another member had the same issue and if I remember correctly the total cost was like 120.00 for repair and shipping
 

·
Registered
Joined
·
31 Posts
Discussion Starter #3
Awesome. I am hoping that is all it needs. I don't really ahve the funds now to buy another one with all the other stuff I had to fix on the bike so far.
 

·
Registered
Joined
·
2,628 Posts
Yeah they need servicing if they dont get much use after a while sitting. Just call Scotts performance and they will get it all working again. One of the best upgrades you can have imo
 

·
Registered
Joined
·
31 Posts
Discussion Starter #5
I have to agree. that's why I'm hoping I can just service this one. Gonna be doin a lotta highway driving so wanna make sure I have a working one.
 
1 - 6 of 6 Posts
Top