Honda CBR 600RR Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
2003 CBR600RR
-Initially headlights weren't working.

-Checked the fuse (the fuse box that was on the left side of the bike behind the fairing) They were two 20A? yellow ones and the rest were 10A red fuses I think. On the fuse box, it showed the headlights being the 20A one. I am not sure how to check the fuse, but I learned that if the little curvy part inside was snapped or disconnected, that means the fuse is blown. After I checked, it was not blown. Still I changed both 20A fuses and switched them around. The headlights still weren't working.

-Checked the bulbs, and decided to just replace one to see if that was the problem. It did not fix the problem.

-Under the dash the wires that lead to the headlights seemed connected, but we were just jiggling it around. These wires have a lot of electrical tape holding them together in various spots, so it's hard to tell if there is a problem behind the tape. The exposed wires did not sure any signs of breaking. After jiggling with the wires and letting a friend drive the bike around, all of a sudden the lights turned on again. The dash lights however turned off. 10-20 minutes later, the headlights and the dash lights weren't working.

-Fed up with this, I decided to just go drive it to the mechanics, but on the way there, the bike completely stopped while I was going maybe 30-40mph.
I couldn't accelerate and just fell to a complete stop. The bike would not start up again. We tried to push it and start it, and we could hear the engine, but it would not turn over completely.

-We decided to check the battery and see if there was something wrong. It turned out the battery was low and we got it recharged. After recharging, the dash was still not working, the headlights were still not working, and the bike would still not start. And the engine cut off switch was in the right position as well.

-Extra information that could be useful is that the button for the starter gets stuck/jammed when pushed and doesn't go back to its original position unless I pull the button out a bit manually.

-Right now my bike is in the parking lot near the area where it died, so I can't look at it right away, or take pictures right away, but does anyone know what I can possibly do? Could it be an easy fix? Or should I just get it towed to a mechanics and have them take care of it?
 

·
Registered
Joined
·
5,093 Posts
sounds like you need a good electrical troubleshooter...

and switches cleaned /wire loom repairs/maybe a new battery depending on it's state.

tow it /or pickup it to a mechs.shop....
 
1 - 2 of 2 Posts
Top