Honda CBR 600RR Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
My Bike Got hit by a fire truck about a month ago...Long story. Anyway I took it to my local honda shop to get it fixed. Today they called me and said "your bikes ready...come and get it." "Oh by the way your blinkers all stay on." So of course I told them to fix it. The service guy said he's not sure why they dtick but they do. Any ideas. I do have LED lights, but have never had a problem with them...
 

·
Registered
Joined
·
3,372 Posts
there's gotta be a short int the line somewhere that's keeping the lights on. troubleshoot the lines to see where it might be.
 

·
Registered
Joined
·
980 Posts
i have the same problem i have my front turn signals on all the time too i thought it was normal how do i fix it? it has been like that for months
 

·
Registered
Joined
·
3,372 Posts
your front sigs will stay on - they are like running lights. if your sigs have 3 wires, they are supposed to stay on.
 

·
Registered
Joined
·
980 Posts
I have an 05 rr so your telling me that they sshould stay on?
 

·
Registered
Joined
·
980 Posts
SO shoul they stay on?
 

·
Registered
Joined
·
3,372 Posts
they should stay on... they are like running lights. as long as they blink when the R/L turn signal is engaged, they are good.
 

·
Registered
Joined
·
176 Posts
Hotskate. If your saying that they don't blink when signaling, then you have hooked up the signal to the hot running light wire and not the hot signal wire.
If you hooked up the signal to both hot wires, it will not blink either.
The above should be correct for a two wire signal.
 
1 - 11 of 11 Posts
Top