Honda CBR 600RR Forum banner

1 - 20 of 31 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
Hey yall Im new to the forum, and Ive tried searchin for this and found something about a speedo healer failing. Im guessing a speedo healer its something to adjust the speeds speed may be when putting a gear kit or something for tuning the speed.

I dont have one of this, and the only thing Ive done to my bike with wiring its installed some HIDs about 3 weeks ago. So the story goes like this, I was just on the onramp of the freeway I was leaning fairly good and then while I was going straight I noticed my FI & HESD light came on. Now I turned the bike off for a second and then key on again to reset it....so the lights were off but speedo not working and I kept my eye on it and neitehr did the odometer, and about a mile or so n then lights came on again.

So now Im guessing that a sensor may be went bad? or loose connection? and therefore with the computer seeing no speed but RPMS flipped the lights on wondering what the hell is going on.

Now my question is have this happened to anyone of you guys? What sensor would that be (prob a Vehicle Speed Sensor I would think) and where is it?
 
D

·
Guest
Joined
·
0 Posts
I believe there has been problems like this with HIDs before (I'll search on that for you). Have you checked the connections on the harness to make sure nothing came loose? Also, check the fuse; this is more then likely the problem.
 

·
Registered
Joined
·
2,412 Posts
ditto on the fuse
 

·
Whoring Is What I Do
Joined
·
5,879 Posts
I've had this happen to me..stupid me my negative batter terminal screw wasn't tightened all the way down. So when there wasn't any pressure against that terminal ( from my ass, everyting would cut out. But when i sat down, and hit my starter button, everything kicked back on.
Check your fuses, batter connection and your harnesses to make sure nothing has become loose.

Doug
 
D

·
Guest
Joined
·
0 Posts
If you have an 03-06 there are some fuses somewhere else. Not exactly sure where they are, but they're somewhere on the front on one of the sides.
 

·
Whoring Is What I Do
Joined
·
5,879 Posts
Dang..the plug to the back of the speedo is completely snug, same goes for everything else?
 

·
Whoring Is What I Do
Joined
·
5,879 Posts
I'm pretty sure 05-06 have 2 sets of fuses believe it or not..I think. I'd have to double check on that now.

Doug
 

·
Registered
Joined
·
18 Posts
Discussion Starter #9
I have a 08. I dont know if their is another set of fuses if their is hook me up to where they are at. I just bought it this year and should be under warranty, but since I havent taken it to the dealer for the services they might try to pull a fast one on me, I called the service department today and the dude seemed like a **** about it askin me bout the services n stuff. So Im trying to check out all the obvious stuff first.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #12 (Edited)
I checked it all out and didnt see nothing loose. What exactly runs the speedo and the odometer is it a speed sensor and where is it at? that and how do u pull codes?
 
D

·
Guest
Joined
·
0 Posts
Not sure where the sensor is, but just count the flashes that the FI light is putting out. A short flash = 1 and a long flash = 10.
 
D

·
Guest
Joined
·
0 Posts
There is no mode to get into seeing the codes, they will flash automatically.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #16
well I turn the bike on and I dont see no codes flashing or nothing is not until I ride for like a mile or no that the FI LIGHT n HESD light come on and stay on until I turn the bike off and on again.
 

·
Registered
Joined
·
145 Posts
When my speedo and odo didnt work....it was because my harness was hot wired and was pretty much burning up...thank god noticed that....make sure no exposed wire is touching each other. Check the harness
 

·
Registered
Joined
·
18 Posts
Discussion Starter #18
Anyone got any suggestion son this? Im gonna b taking it to the dealer next week if they have any openings if not the week after that, but its my only "legal" vehicle right now so Im trying to get sum answers.

One of you guys suggested reading the codes, but I dont see nothing flashing or anything. The FI and HESD lights come on, first the FI light and a second later the HESD right after. and then they stay on until I turn off the bike. N then its clear again they dont flash or nothing.

So to pull that code of what happened, how do I get it to flash? I should just be able to put it in Run and it should flash..? Cause it makes no sense, even in my prelude I had to bridge a connector and then I would put the key on the Run position n it would flash me the codes. Also any Honda Bike Techs in the forum?
 

·
Registered
Joined
·
3,672 Posts
to test the blink pattern
from page 6-14 of the service manual

turn ignition switch on with kill switch to run.

MIL light should start blinking
long blinks are 1.3 seconds
short blinks are .5 seconds
if there is a current problem the mil will blink immediatly

if it is a stored problem not currently happening you must remove the cap off of the dummy connector under the seat and use the HDS pocket tester

count the blinks like this
example
2 longs + 5 shorts= trouble code 25.


sidestand must be lowered



check the plug to the back of the dash,
it may be loose.
also check the plug to the HESD


on dealer service, in the US
by law (the magson moss act, check spelling i can never spell this thing right)
the dealer can only deny warranty service to you if they can prove a modification you installed yourself caused the problem. they cannot deny warranty solely because you didnt take it to them for service.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #20
thanks for the whole thing, including the dealer service deal.

I have checked the plug going to the hesd, the only thing I havent checked is in the back of the dash....what all do u have to take off. and which one is the dummy connector, what color is it, im guessing the hds tester its just sumthing like a paper clip? Im guessing taking the side fairings n taking the front cowl apart...
 
1 - 20 of 31 Posts
Top