Honda CBR 600RR Forum banner
1 - 16 of 16 Posts

· Registered
Joined
·
441 Posts
Discussion Starter · #1 ·
well i laid my bike over last night...yea it sucked..but just a little cosmetic damage..hit the starter button and it just clicks..everything cuts on injectors, lights, etc. but wont start ...any advice is appreciated..
 

· Registered
Joined
·
441 Posts
Discussion Starter · #7 ·
i checked the fuses on the solenoid and the battery terminals..bas is ok because the fuel pump turns on..the clicking noise is coming from under the seat at the battery..i think it may be the solenoid but how could laying it over fry that?? im at a loss here.
 

· Premium Member
Joined
·
53,946 Posts
charge your battery bro and it will fire up
 

· Registered
Joined
·
80 Posts
same thing minus the drop happened with me charging it didnt even help.....had to buy a new one and vrooooooom

if you take it to autozone all they can tell you is how much voltage ours put out. at the time mine read 12.4 which isnt enough apparently its suppose to be 13.(something)
 

· Registered
Joined
·
441 Posts
Discussion Starter · #13 ·
well i work at a honda dealership..just gonna take it to the service dept. and test and charge myself...i just cant afford their 65.00/hr labor rate. even working here i get no discount on labor..just parts.
 

· Registered
Joined
·
441 Posts
Discussion Starter · #15 ·
well its been about 3 weeks and i finally had time to try a few things..all i had to do was charge the battery..i dont understand how laying it over would do this but oh well easy cheap fix...thanks for the input everybody.now i just gotta find a cheap rh fairing...
 
1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top