Honda CBR 600RR Forum banner

1 - 20 of 23 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1 (Edited)
Hey everyone, I recently bought a used bike and I'm already having problems...

The tach needle on my 2006 stopped moving. It stays put around 2,500 RPMs, even on startup. The bottom left LED on the revolution circle is also out. Everything else on the cluster is working (clock, speedometer, temp, fuel, indicators, etc.).

What's interesting is the LED sometimes flickers on/off when riding, and sometimes the needle flicks up randomly (but I haven't seen it do that in awhile).

I pulled some pictures from Google to help show the problem. The attached picture shows the LED I'm referring to.



Any ideas? I'm thinking if it was a fuse, more things would be broken than just the needle?
 

·
Registered
Joined
·
836 Posts
Perhaps the LED that has stopped working has come loose and is now blocking needle movement? Does the needle seem to want to move at all? And is it still stuck in the same spot while powered down?


Sent from my Motorcycle iPad app
 

·
Registered
2003 Honda CBR 600RR
Joined
·
6,790 Posts
i've had worse when my gauge acted funny, first the tach needle stopped moving then all of the digital displays started screwing around until it no longer had any display & this was a couple of days before my race, tried to fix it by removing the gauge cleaning the internals & connections but still no luck so i just said fack it & left it alone, a couple of hours later the damn thing all worked again.

i thought i was going to buy a new gauge, very mystifying.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4 (Edited)
Lately, the needle has been staying at the same spot, doesn't matter if it's on or off. It vibrates a little when riding, but not enough to move it. A few weeks ago it would randomly jerk up and down, but I haven't seen it do that in awhile.

It's weird because the needle stays around 2 even when powered off, instead of just hanging loosely at 0. The needle also doesn't even budge when starting up.

The LED doesn't look loose or anything, and it's definitely not blocking the needle.
 

·
Registered
Joined
·
1,125 Posts
Does the needle swing all the way up when you turn on the bike? The normal cycle through, as the speed goes all the way as well?

Try checking the back of the gauges to make sure everything is plugged in all the way then check each wire, maybe a wire got loose.

I had the same problem, the needle would swing all the way up then nothing when I rev'd the bike. It was an ECU issue for me, replaced it and worked fine. Try seeing if you know anyone and switch gauges and ECU.
 

·
Registered
2003 Honda CBR 600RR
Joined
·
6,790 Posts
ecu issue? damn i hope not because if it happened to me i'll have to replace the entire wiring harness & switches because i have HISS.
 

·
Registered
Joined
·
836 Posts
As far as know the ECU is nearly indestructible! If its anything it's not that! So if it is you are a one of! The ECU is just a translator, if anything it would relate info incorrectly but even then it would manifest in other areas as well! For instance a rev needle error would also affect gas mileage and result in back fire etc.


Sent from my iPhone25S(27ft by2.5in screen)
 

·
Registered
Joined
·
10 Posts
Discussion Starter #9
Thanks for the help so far everyone!

Do you think maybe the ECU came a little loose? I won't be able to work on it until the weekend, but yesterday I took the windscreen off and tried to push the plug in on the gauge. No luck.

Might try to take off the front fairing to get a better looksie of everything...
 

·
Registered
2003 Honda CBR 600RR
Joined
·
6,790 Posts
impossible for the ECU to get loose with how the sockets are connected, try getting a can of electronic contact cleaner & spray the connections going to the gauge & ECU, let dry & plug them in again, cross your fingers.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #12
check fuses..similar think happened to my 03 and i figured out it was a fuse blown
would a blown fuse only affect a LED and the needle? I believe I was reading somewhere that the fuse related to the gauge controlled multiple things...

I'll still take a look tomorrow, and maybe take a look at the ECU :/
 

·
Registered
2003 Honda CBR 600RR
Joined
·
6,790 Posts
a blown fuse would disable the gauge altogether.
 

·
Registered
Joined
·
1,331 Posts
Are the LEDs in your cluster stock(orange) or changed in color like the one in the picture? If they have been changed, it is likely they unsoldered the tach needle. May have not gotten a good solder joint when reinstalling.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #15
I asked the previous owner and looks like he changed the LEDs to red and white. I'll take a picture as soon as I get reunited with the bike. Damn... what a hassle lol
 

·
Registered
Joined
·
350 Posts
Looks like it has been modified. I'm not sure how people change the color like that but if you have to solder LEDs to the board, that is very easy to **** up. Hehe I had a very similar issue, it ended up being that two wires were pinched in the middle of the harness. Honda uses incredibly cheap wiring.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #18
Sorry for the wait, but here's the picture of the cluster



Needle stays in that position no matter what now, but speedometer registers fine.

As you can see, the bottom left LED is out. It was working when I was about to take the picture, but went out right before I pressed the shutter. It seems to do what it wants.
 

·
Registered
Joined
·
350 Posts
My first guess is the cluster board is messed up because it was improperly soldered. Those modifications have to be done extremely delicately. Other than that it could be wiring. Try taking off a couple fairings and wiggling the harness.
 

·
Registered
Joined
·
254 Posts
Another thing to consider is that something on the circuit board may be shorting out. Check for any solder that might be shorting out two or more traces on the circuit board. The person that did this mod might have accidentaly gotten solder on the board where it shouldn't be.
 
1 - 20 of 23 Posts
Top